I have just gotten a new PC and I am very happy with it! However, whenever I open the computer from sleep, the keyboard repeat rate has reverted to the default. The default for windows 8 is hellishly slow, and thus I would like to not have to change the setting every time. Already checked all of the filter keys stuff, and it is still too slow, and that does not help. Thanks for the suggestions!

up vote 2 down vote accepted

There is a bug in Windows that causes that behavior. To fix it follow these instructions:

  1. Download NirCmd
  2. Put nircmd.exe in your Windows folder
  3. Open Task Scheduler
  4. Create new task and name it as you wish
  5. Crete new trigger with these settings: (Begin the task: On an event, Log: System, Source: Power-Troubleshooter, Event ID: 1)
  6. Create new action with these settings: (Action: Start a program, Program/script: nircmd, Add arguments (optional): execmd mode con: rate=32 delay=1)
  7. In Conditions tab uncheck "Start the task only if the computer is on AC power)
  • This is literally the best answer ever my friend! I have been waiting to fix this for so long, and haven't known how! If I could up vote you I would! This is the best thing ever! Thank you good sir! – Nick P May 25 '15 at 3:08

Actually, you can do this without NirCmd. For program/script, put mode. For arguments, put con: rate=31 delay=1 or whatever your preference is.

Also, if you prefer a different repeat rate, you can go to a command prompt and run mode con to see what your current settings are.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.