I installed Windows 8.1 Enterprise via Bootcamp on my MBP (Nov 2013 model), now I can only boot into Windows, no way to boot into OSX.

When I hold the ALT button at boot, the menu shows only Windows and there is no option to boot OSX.

When I select "OSX" from the control panel Bootcamp utility, and reboot, the system goes into Windows regardless. Windows works just fine (I'm using it now) but my main setup and a lot of work in progress is on OSX so I really need to recover it. Anyone knows how to recover the OSX partition, so that I can boot into OSX ? I'm happy to drop Windows if that's the case, but I cannot proceed with a fresh install wiping OSX.

The laptop is a MacBook Pro November 2013 model, with one original SSD drive (without DVD drive, however I have an external one) and I don't have a OSX installation disk, so I could not try recovery utilities etc.

I have tried a couple of Windows utilities, trying to change the Active partition, but for some reason that option is always grayed out, even DiskPart doesn't allow to set it.

I checked Disk Management and the OSX partition is still present (partition 1):

Disk 0:
Partition 0: 200 MB    - EFI System Partition
Partition 1: 837.57 GB - Primary Partition
Partition 2: 620 MB    - Primary Partition (no idea what this is for)
Partition 3: 93.47 GB  - Boot, Page File, Crash Dump, Primary Partition

and this is the output of MS DiskPart utility:

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          931 GB      0 B        *

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> list partition

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    System             200 MB    20 KB
  Partition 2    Unknown            837 GB   200 MB
  Partition 3    Unknown            619 MB   837 GB
  Partition 4    Primary             93 GB   838 GB

DISKPART> select partition 1

Partition 1 is now the selected partition.

DISKPART> active

The selected disk is not a fixed MBR disk.
The ACTIVE command can only be used on fixed MBR disks.

This How do I make my Boot Camp partition bootable again? seems to be very close to my problem, but rEFIt is distributed in CDR format, I tried to convert that to ISO and burn to a USB with no luck, the system won't see the USB.

Anyone knows of other ways to fix Bootcamp loader to show OSX partition ?

  • One of those partitions ought to be the Recovery partition. Did you try Cmd/R at boot? support.apple.com/kb/HT4718 – Tetsujin Sep 12 '14 at 8:14
  • UPDATE: after many tests I went to one Apple store and they had a hard time recovering the system too. We managed to mount the encrypted partition and extract the data to a USB drive, using one Apple bootable tools images (which they wouldn't share). Once I recovered the data we wiped the system and started fresh. What I learned is not to install a 2nd OS if the MacOS partition is encrypted. First decrypt, then install, then perhaps re-encrypt. I haven't tested it though, so please don't take this for sure. – Devis Lucato Sep 28 '16 at 19:18

I had the same error after installing windows in bootcamp. I rebooted and the OS X partition was not an option, only windows. I checked in disk management in Windows and the partition still existed. I tried booting in recovery mode (command+r), but received an error message. -4403F

Apple support had me boot in internet recovery mode (command+option+r), which did successfully load.
I then went to disk utility, and the Macintosh HD disk was grayed out. I clicked on the mount/unmount button and had to unlock my computer. It turns out I had used file vault, which encrypted my hard drive.

Somehow that kept OS X from appearing after I used bootcamp. After unlocking it, I was able to verify and repair the disk.
I booted to windows and the bootcamp utility appeared. I clicked "Restart in OS X." OS X booted without a problem after that.

|improve this answer|||||

Yours is quite a new model of MacBook Pro : Your firmware would be UEFI compliant. On such machines Windows can use GPT disk partitioning and boot from your firmware boot menu without any need of BootCamp. What BootCamp does is to apply an ugly hack to make it look like being an MBR partitioned disk to Windows, which can then boot via BIOS.

What seems to have happened is that your Windows seems to have switched modes at some time, and has established itself as a UEFI-booting OS on GPT. BootCamp as a bootloader is now no longer required.

Your firmware boot menu would have originally contained only an entry for Mac, and for some unknown reason Windows Setup seems to have wiped it out.

In short, what you need to do now is to add a new boot entry in your firmware menu pointing to your OS X bootloader, which I have gathered from the web to be /System/Library/CoreServices/boot.efi on your HFS+ volume. However, I understand that it is enough just to specify your HFS+ volume for it to boot. I am however ignorant of the UEFI boot process and firmware on Mac, someone else should be able to help you here to add the entry.

|improve this answer|||||

Start over with Bootcamp...

This is from wiping the HDD instead of partitioning within BootCamp; which leaves no way to communicate with Apple's server. OS X install is electronic. Windows includes the option to turn off "secure boot"; ARM and Apple do not. OS X requires BootCamp and a small Apple partition, similar to Windows Boot Loader. I have BootCamp and the Apple partition, but only Windows 8 only on my Mac. There is no native support to re-install OS X from this configuration, either. I am guessing I can manually create a partition that OSX will recognize....some other day. EUFI is not standardized, yet.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.