3

I am unable to connect to gmail chat through pidgin (2.10.9) on Debian.

But Facebook chat is working fine.

Have tried this:

  1. Google support https://support.google.com/a/answer/49147?hl=en
  2. a blog suggestion

Telnet shows

$ telnet gmail.com 5222 
Trying 74.125.236.86... 
Trying 74.125.236.85... 
Trying 2404:6800:4007:801::1015... 
telnet: Unable to connect to remote host: Network is unreachable

Tried pidgin FAQ suggestion

at console

dig +short SRV _xmpp-client._tcp.gmail.com 

gives

5 0 5222 xmpp.l.google.com.
20 0 5222 alt4.xmpp.l.google.com. 
20 0 5222 alt2.xmpp.l.google.com. 
20 0 5222 alt1.xmpp.l.google.com.
20 0 5222 alt3.xmpp.l.google.com.
  • Check your netwrok. There seems to be some issue – frlan Sep 12 '14 at 7:04
  • I have internet access.Also, fb chat is working with pidgin. What else can I check, any suggestion? – AAI Sep 12 '14 at 7:12
  • your firewall seems to be blocking those ports. – Sathyajith Bhat Sep 12 '14 at 9:27
3

Enabled allow less secure apps option in Google account. This solved the problems with all the standard pidgin settings for the gtalk.

| improve this answer | |
  • 1
    Not the greatest solution, since it explicitly makes your account less secure. Is there any way other than this? – Nicholi May 28 '15 at 20:31
1

The question is rather old, but I still encountered this problem today. So, here's a solution. Use these settings in the advanced tab:

Connection security: "Use old-style SSL"
Connect port: 5223
Connect server: talk.google.com

Particularly setting the Connect server appears to be important.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.