1

I have a new, unpartitioned(not touched*) Intel 330 180GB SSD on my Desktop to which I plan to install Debian testing. I use a 160GB Disk with Ubuntu to which, this SSD is now installed. I ran latest gparted live cd and issued "hdparm -I /dev/sda" and it showed as frozen:

Security: 
Master password revision code = 65534
    supported
not enabled
not locked
    **frozen**
not expired: security count
    supported: enhanced erase
4min for SECURITY ERASE UNIT. 2min for ENHANCED SECURITY ERASE UNIT. 

So, Shall I do a secure erase before installing OS?

UPDATE This is a Intel 330 180GB SSD sitting idle in my shelf for 2years and have just connected it to my pc. What I did was, tried to update the firmware from Intel's firmware update bootable live cd and it returned saying, everything is OK. can not find what went wrong or am plane unlucky!
UPDATE gparted recognizes the SSD and I can even format a msdos disk label to the SSD. very confusing! UPDATE - Apparently, SSD drive gets locked down due to security freeze set by motherboard BIOS. since hdparm shows "not locked, frozen" state, harddrive/SSD encryption will not work. I have seen a link where the BIOS jumper setting can be put in configuration mode for advanced features. still ,it doesn't offer anything. However, you can install on SSD fine as verified by Intel community forums and here: https://communities.intel.com/message/251978#251978 and https://wiki.archlinux.org/index.php/Solid_State_Drives#Hdparm_shows_.22frozen.22_state

  • Are you asking if you should or trying to get a vote of predictions if you will? – Ramhound Sep 12 '14 at 15:18
  • I am new to SSD's and wonder why a new, untouched SSD shows "frozen" status. – Number79 Sep 12 '14 at 15:22
  • There are lots of possible reasons for the frozen status but there isn't enough information for us to tell you that reason just unfreeze it using any number of methods – Ramhound Sep 12 '14 at 15:43
  • I've updated my post. in brief - this ssd is just connected to the system, which also has a dying 160GB seagate sata hard disk. – Number79 Sep 12 '14 at 17:19
  • Can you try the following: Boot with the SSD connected to the laptop. During the boot the BIOS will set the SSD status to 'frozen' to protect it from changes. Once booted suspend the laptop (not a full power cycle). Unplug the SSDs power (which I realize might not be possible in all laptops). Replug it after a few seconds. The drive is now in an unfrozen (thawed?) state. Resume and pray that the resume does not do the same as a cold boot. – Hennes Sep 12 '14 at 18:00
2

On at least some laptops (where disconnecting SATA power may prove... challenging), simply putting the laptop to sleep then waking it back up is sufficient, since it also power cycles the drive.

This was tested with a Lenovo T430 and a Samsung 840 EVO mSATA drive, where I was able to issue a secure erase from KUbuntu booted from a flash drive (Live CD environment) using hdparm following Samsung's instructions from Samsung's SSD FAQs on performing a secure erase in different OS environments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.