21

Is the option to enable ssh access to this router not available in the stock version of the firmware?

I can only see "Enable Telnet" under Administration -> System.
That's kind of lame. Telnet is sent over the network in plain text and is not secure. I have firmware version 3.0.0.4.376_1071 and that is the latest version according to the check for updates feature on the router.

If you Google around, other people have been talking about SSH access into this popular router. Are they using some custom firmware?

3

are they using some custom firmware?

Yes, most owners of this router use custom firmware like tomato or mods thereof.

| improve this answer | |
  • 1
    Someone care to explain the downvotes? – Jan Mar 4 '16 at 6:34
3

Even though this is a year old I wanted to chime in with what I found because I was just now trying to get sshd working on the same router after reading similar pages.

I'm using version 3.0.0.4.376_3861 and they still haven't added in sshd. I got a chuckle out of the hidden ssh options in the menu. They are still there, but don't work. I telnetted in and did nvram show | grep ssh. Nothing was already there, but I tried shinji14's answer anyway. I tried with reboot too, but nmap still showed no SSH on a port scan. I then telnetted back in and tried ls -alR --color=always | more and after scanning the results I saw that they are using BusyBox. I couldn't remember if BusyBox had sshd built in so I did busybox --help and didn't see it in the list.

BusyBox's site mentions Dropbear for sshd here, so it looks like they are likely using a WRT variant like 0xC0000022L mentioned or they may be putting Dropbear on it. I'll probably end up trying Dropbear myself. If that works then I'd say it'd be the way to go because one could pretty much keep it stock and then just put it back on anytime an official update is installed.

| improve this answer | |
2

According to its author, the customized version of AsusWRT named AsusWRT-Merlin supports SSH in the form of dropbear.

Search for "SSHD" in this README.

Check out the Github website and build your own or follow the download link at the bottom.

Also note: AsusWRT was originally a fork of Tomato. It diverged quite a lot since then, but if you only need a version that is somewhat enhanced over the offer Asus makes on its firmware download page, this may be the right thing for you.

| improve this answer | |
0

If you debug the router webpage, in the administration tab you can see that the ssh row is hidden with style display:none;

You can go through telnet and set the values with

nvram set sshd-enabled=1
nvram set sshd-port=22

You can find those values in the apache server of the router, checking the source code of the router webpage.

| improve this answer | |
  • This did not work for me. I have firmware 3.0.0.4.376_3861. I did find / -name ssh -print as well as -name sshd and came up with nothing. – pedz May 18 '15 at 14:23
  • I agree. This looks good, but it does not work. Yes, the HTML is hidden using JavaScript. You can open your web console and type $('ssh_table').style.display=''; to show it. But setting the nvram value does not cause it to be displayed when reloading the page, and showing it, clicking the "Enable" button and applying does not turn SSH on. – Phrogz Oct 29 '15 at 3:31
  • 1
    I think in order for nvram changes to work, you need to do nvram commit and restart router (reboot.) But after doing that on the latest firmware (3.0.0.4.378_9459-g7ddc2c6) I can't connect with ssh on that port ("connection refused".) – Carl G Apr 16 '16 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.