1

I just upgraded my router to DD-WRT v24-sp2 (05/12/14), and I’m trying to configure port forwarding. I opened port 80 to go to a server, but whenever I connect from the outside world, I get timed out.

My firewall is disabled on the router, the port forwarding setting is correct and I know I have access to 80 from the outside. If I access the url from inside the network, it takes me to the DD-WRT info page.

Is there a way to configure all requests to the WLAN address to follow port forward rules but if I connect to 192.168.1.1 from my home network, it takes me to DD-WRT?

1

Most likely, you you need to uncheck Security -> Firewall -> Filter WAN NAT Redirection.

  • It is unchecked and the firewall is disabled anyway. It's worth mentioning that port 80 is the only one that doesn't behave. Minecraft and SSH seem to work. 80 always goes to the info page. – Osmium USA Sep 13 '14 at 11:59
0

This thread is old, but there is a software solution which still applies to older builds of DD-WRT. I had the same problem and found the answer here. The command is: iptables -t nat -A POSTROUTING -j MASQUERADE Similar commands are listed here.

  • 1
    Although this may answer the question, you should give a more detailed description of the linked content and explain how it relates to the question. This will help ensure that this answer remains useful in the event the linked page is removed or goes offline. For more information, see this Meta Stack Exchange post. – bwDraco Jan 18 '16 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.