1

I have created a Ubuntu 14.04 VM on Virtualbox 4.3.16 (running on Windows 8). I have installed all of the Ubuntu virtualbox-guest* packages.

The highest screen resolution that I can set in the Ubuntu VM is 1280x960 (4:3). The other options are 1024x768 and 800x600. What I really want is to set the screen resolution to be identical to that of the host OS. ie. 1920x1080.

Does anyone know how to do this?

1

Make sure you have Auto-resize Guest Display ticked, under the View drop-down menu (Host + G). You can tell what it's currently set to by its tiny icon. Then try moving the window around, i.e. restoring it down/maximising.

Ubuntu should then automatically scale its display with respect to its window size.

0

Do try resizing the guest display from the Host Virtual-box view settings.

Just because you install the guest-packages doesn't mean they are being used. I had problems with Windows 7 host -> Ubu 14.04 guest, vboxvideo would not load successfully. If your Xserver is failing to load that driver, and you have not provided any alternative fallbacks, that could also explain why Xserver is limiting your display resolution size.

Try booting your VM in fullscreen mode right from the start (instead of maximizing after gdm has loaded). If it won't adapt to fullscreen automagically, your Xserver either needs some configuration or some additional packages installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.