1

Recently I've been starting to use Vagrant v1.6.5 running on VirtualBox v4.3.14 for my PHP development. Following this tutorial of PhpAcademy, I was able to setup and run Vagrant on my Windows machine running Windows 7 Professional x64.

The following day, I wanted to run vagrant, but it said it got stuck in the aborted state. Googling around for a bit resulted in finding this question on Serverfault, which was the only sensible link I could find. Trying the solutions listed there yielded no different results, it was still stuck in the abandoned state.

I then tried to delete the vm and re-creating it, which resulted the vm to get stuck in the powered-off state. Then I tried to delete the Vagrantfile too and re-creating that... same result.

Why is this happening and how can I fix it?

Edit 1

By request, the log message from Vagrant through the command line is:

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'ubuntu/trusty64' is up to date...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
==> default: Forwarding ports...
default: 80 => 8081 (adapter 1)
default: 22 => 2222 (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
The guest machine entered an invalid state while waiting for it to boot. Valid states are 'starting, running'. The machine is in the 'poweroff' state. Please verify everything is configured properly and try again.

If the provider you're using has a GUI that comes with it, it is often helpful to open that and watch the machine, since the GUI often has more helpful error messages than Vagrant can retrieve. For example, if you're using VirtualBox, run vagrant up while the VirtualBox GUI is open.

Through VirtualBox I get the following error popup:

Error relaunching VirtualBox VM process 5
Command line: '81954AF5-4D2F-31EB-A142-B7AF187A1C41-suplib-2ndchild --command yacs_default_1410526815120_40382 --startvm f9b81b25-e24a-4e13-980d-80792f8da977 --no-startvm-errormsgbox' (rc=-104)

migrated from serverfault.com Sep 13 '14 at 13:38

This question came from our site for system and network administrators.

  • can you post the log messages? also, try to start the vm through the virtualization tool you're using directly, without vagrant, see what's wrong there. – Giovanni Tirloni Sep 12 '14 at 12:45
  • I don't have the former log message, but I do have the latter. I tried launching the vm using VirtualBox, which also pops an error. I'll update my question and tags on it. – MisterBla Sep 12 '14 at 12:56
  • Looks like a bug recently fixed: virtualbox.org/ticket/13187 – Giovanni Tirloni Sep 12 '14 at 13:12
  • I uninstalled VirtualBox and I'll install 4.3.16 tomorrow. If that doesn't work I'll downgrade to 4.3.12. I'll let you know. – MisterBla Sep 13 '14 at 1:02
  • @gtirloni Can you post your comment as an answer? Upgrading to 4.3.16 solved the issue. I uninstalled VirtualBox 4.3.14, rebooted PC. Installed 4.3.16 and re-initialized my vagrant instance. I then ran and installed it with Apache, PHP and MySQL, successfully loading up a local server. The next day after booting my PC I started the VM again which now succeeeded. – MisterBla Sep 16 '14 at 16:40
2

As said by @gtirloni this is a bug in VirtualBox, I fixed it by uninstalling VirtualBox 4.3.14 and installed 4.3.16. It now works as intended.

  • I also heard of people solving the problem by downgrading VirtualBox, and I just solved it by upgrading from 5.0.0 to 5.0.12. I think something about the installation process is the real fix. – Noumenon Jan 11 '16 at 0:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.