1

i am using manjaro linux, and i installed vim using

$ sudo pacman -S vim

then i modified my vimrc file

$ sudo vim /etc/vimrc

then i added some cool things:

set background="dark"
set number
set shiftwidth=2
set scrolloff=5
set autoindent

but when i try to edit another file, the line numbers have been indented, and the bottom panel where it tells me if im in insert mode doesn't work, and backspace does not work even in insert mode, hope someone can help me. thanks =)

1

then i modified my vimrc file

No. That file is not your vimrc file.

Remove everything you have added to /etc/vimrc and put it in your ~/.vimrc.

Since we are at it,

  • you don't need to quote "dark" (which doesn't do what you probably think it does anyway),
  • none of those settings have any effect on showing the current mode or the behavior of <Backspace>.
3
  • 1
    Why is that? I use /etc/vimrc as a global config file because I want the settings for every user. I see no problem using this as config file as long as ~/.vimrc has the line source /etc/vimrc.
    – ap0
    Sep 15 '14 at 8:34
  • @ap0, but you are not the OP, right? As an admin you want all your users to have the same settings, as the single user of his own machine he only wants himself to have his own settings.
    – romainl
    Sep 15 '14 at 9:13
  • 1
    I am also a single user. By "all users" I ment my default account and root. I only wanted to point out that it is ok to use the global vimrc. In your post it felt a little bit that you discourage using that file. But maybe this is a matter of opinion. :)
    – ap0
    Sep 15 '14 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.