4

I have a theory and I kindly ask the skilled linux users to confirm/deny it (I am not a skileld one at all). Im running:

Raspberry Pi model B+, Raspbian OS and CUPS 1.5.4

And I bought the SEWOO LK-TL322 POS printer.

The printer is supposed to support Linux CUPS driver they provide. Ok according to their 2 pages long simple manual (link down) I was able to install the printer. Worked in 1 min like a charm.

But, with the printer driver, a filter was installed - rastertosewoo filter which is failing with every print job, no matter how simple it is (error massage: rastertosewoo filter failed). I googled what a filter is and found out its a layer of editing the content to be printed to fit the next layer or finally the printer. This is the last layer provided by the manufacturer - guessing from the logs, since its the last filter to be started.

Theorys / Ideas:

1. Is it possible that the manufacturer says it supports "Linux CUPS" but does not say that only for some architectures? That the ARM architecture (raspberry pi) could be a filter issue?

2. If it is so, is there a way how to make it work for ARM? (I dont haev the filter sources, I just got a compiled filter) - recompiling the compiled?

3. Is there any generic linux "driver" that is simmilar or supports POS printers like this?

4. In the manual, the manufacturer informs about these two distro types: (Ubuntu) vs (SUSE, Fedora Core, RedHat) - could Raspbian be a isse (and not ARM)? I have read that Ubuntu and Debian are VERY close and that Raspbian is build on Debian so that should work .. am I correct?

5. I have read, that if a printer supports natively PostScript - it does not really need a driver, adn if my printer would support PS natively I could just add it as RAW printer and use it like that. I tried that, I am able to print ASCII but the moment I try to print a image I get a looong (200+ lines) printed output starting

%!PS-Adobe-3.0
%%BEGIN PROLOG
...

Does that mean my printer supports PS or not?

Last info: Yes, I contacted the manufacturer, without response yet and I highly doubt there will be any. Regarding POS printing on linux, I should look for something that supports natively PS and/or is covered in GHOST printer driver?

Thank you for any inputs or anything that could help me.. I could not sleep and am highly depressed, becasue it works like a charm on windows and doing trouble on linux :(

Links:

  • Just a comment. I just installed debian on a x86 machine and tested the driver there. Worked like a charm. So yep some filters have problem with ARM architercure obviously ... Damnit. anyone wants a POS printer? :) – Oliver Goossens Sep 15 '14 at 2:17
  • I was just contacted by the manufacturer, that they will provide a ARM based driver (filter) in the next days. Will upload for all and let you know. – Oliver Goossens Sep 15 '14 at 13:06
2

Yep, the FILTERs are architecture dependent and after contacting the manufacturer he compiled and provided the ARM build for this driver (worked like a charm):

My dropbox link for users facing same problem: https://dl.dropboxusercontent.com/u/17524455/nodelete/SEWOO_CUPS_ARM_Driver.zip

  • 2
    Hi, your Dropbox link is no longer working. Could you perhaps upload it again? I will then mirror it. – Daniel B Nov 2 '14 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.