-2

I have three devices on my home network.

  • This computer, which runs Windows 7,
  • my phone, which runs android,
  • and a laptop, which runs chrome OS.

My computer has a stable, normal internet connection, however neither the laptop nor my phone can reach the internet since yestreday. They both have similar problems.

My phone says it is connected to the internet, but acts exactly the way it does when it is not, whilst the laptop is connected to the internet, but there is a little "!" next to the wifi symbol on the computer.

When I log in to the laptop, a message appears in the bottom right-hand corner saying "Action Required". When I click on it, it links me to "http://www.gstatic.com/generate_204". Otherwise, it behaves exactly the way it does as when it is not connected to the internet.

How can I get these two devices to connect to the internet again?

5
  • Are all the devices using wi-fi? Are all the devices connected to the same access point? Sep 14 '14 at 14:13
  • Yes, and I think so. That means the same router right?
    – Yaxlat
    Sep 14 '14 at 14:15
  • I would try powering the router off and on (or rebooting through the interface) before I tried anything else.
    – AFH
    Sep 14 '14 at 14:18
  • I am assuming you have a wifi-enabled router at home. Suppose your wifi is named "yaxlat". My question is: Is your Win7 PC not connected via cable, but only via wifi, to "yaxlat" wifi, and your phone too, to the same "yaxlat" wifi, and your notebook too, to the same "yaxlat" wifi? And then only the PC can open websites? Sep 14 '14 at 14:19
  • Yes, that is exactly it :)
    – Yaxlat
    Sep 14 '14 at 14:26
0

It is possible that your router is blocking internet access based on MAC address filtering. Access your router's administrative interface to verify this. It is usually done by opening a browser page on the router's IP address (you can discover your router's IP address by performing ipconfig on the Windows command line and checking the "gateway" entry").

0

The solution is that you must FORGET THE NETWORK on all devices with the issue, then restart your rooter, and then reconnect the network with said devices, this last step will require you to reenter the password for the internet, if you have one in the first place. When I tried to do this without forgetting the network, it did not work. Results may be different for you, but doing this extra step will insure safety. I have no idea why this problem was not also with my desktop. I hope this helps anyone with a similar problem in the future :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.