0

When I plug in my WD My Passport, I can't see it in File Explorer. However, I do see it in "Device Manager" under "Disk Drives".

I tried updating the driver, etc., which didn't solve the problem.

  • Go to Start, type in compmgmt.msc, and press enter. Then go to "Disk Management" under Storage. Do you see your drive there? – Mike Koch Sep 14 '14 at 15:50
  • no, it isn't there..tried to update firmware (was successful but still drive isn't detected..) – user1025852 Sep 14 '14 at 16:03
  • mm wait I see 1T unallocated... – user1025852 Sep 14 '14 at 16:04
  • wierd, I gave it a letter, he forced me to format (I did) and now it is available as another drive...ok so it seems to work in some weird level..thanks you very much for the tip. – user1025852 Sep 14 '14 at 16:06
0

perhaps your disk has no partition on it ? Go to disk manager in computer manager and check your disk contents.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.