1

I have Filezilla running on windows server 2008 but I can't figure out how to allow uploads. I'm getting a permission denied or can't access file error. How can I give Filezilla access to the upload directory?

I get the can't access file error when I check (file) delete for shared folder and permission denied when it is unchecked...

(000611)15/09/2014 08:48:26 - cduve (10.100.3.61)> 230 Logged on

(000611)15/09/2014 08:48:26 - cduve (10.100.3.61)> PWD

(000611)15/09/2014 08:48:26 - cduve (10.100.3.61)> 257 "/" is current directory.

(000611)15/09/2014 08:48:26 - cduve (10.100.3.61)> CWD /dataportal

(000611)15/09/2014 08:48:26 - cduve (10.100.3.61)> 250 CWD successful. "/dataportal" is current directory.

(000611)15/09/2014 08:48:27 - cduve (10.100.3.61)> TYPE A

(000611)15/09/2014 08:48:27 - cduve (10.100.3.61)> 200 Type set to A

(000611)15/09/2014 08:48:27 - cduve (10.100.3.61)> PASV

(000611)15/09/2014 08:48:27 - cduve (10.100.3.61)> 227 Entering Passive Mode (10,31,28,8,234,115)

(000611)15/09/2014 08:48:29 - cduve (10.100.3.61)> LIST -a

(000611)15/09/2014 08:48:29 - cduve (10.100.3.61)> 150 Opening data channel for directory listing of "/dataportal"

(000611)15/09/2014 08:48:29 - cduve (10.100.3.61)> 226 Successfully transferred "/dataportal"

(000611)15/09/2014 08:48:30 - cduve (10.100.3.61)> TYPE I

(000611)15/09/2014 08:48:30 - cduve (10.100.3.61)> 200 Type set to I

(000611)15/09/2014 08:48:30 - cduve (10.100.3.61)> PASV

(000611)15/09/2014 08:48:30 - cduve (10.100.3.61)> 227 Entering Passive Mode (10,31,28,8,234,116)

(000611)15/09/2014 08:48:32 - cduve (10.100.3.61)> STOR configuration.php

(000611)15/09/2014 08:48:32 - cduve (10.100.3.61)> 550 Permission denied

Retrieving account settings, please wait...

Done retrieving account settings

Here I checked delete option for files enter image description here

Sending account settings, please wait...

Done sending account settings.

(000611)15/09/2014 08:48:55 - cduve (10.100.3.61)> TYPE A

(000611)15/09/2014 08:48:55 - cduve (10.100.3.61)> 200 Type set to A

(000611)15/09/2014 08:48:55 - cduve (10.100.3.61)> PASV

(000611)15/09/2014 08:48:55 - cduve (10.100.3.61)> 227 Entering Passive Mode (10,31,28,8,234,117)

(000611)15/09/2014 08:48:57 - cduve (10.100.3.61)> LIST -a

(000611)15/09/2014 08:48:57 - cduve (10.100.3.61)> 150 Opening data channel for directory listing of "/dataportal"

(000611)15/09/2014 08:48:57 - cduve (10.100.3.61)> 226 Successfully transferred "/dataportal"

(000611)15/09/2014 08:48:58 - cduve (10.100.3.61)> TYPE I

(000611)15/09/2014 08:48:58 - cduve (10.100.3.61)> 200 Type set to I

(000611)15/09/2014 08:48:58 - cduve (10.100.3.61)> PASV

(000611)15/09/2014 08:48:58 - cduve (10.100.3.61)> 227 Entering Passive Mode (10,31,28,8,234,118)

(000611)15/09/2014 08:49:00 - cduve (10.100.3.61)> STOR configuration.php

(000611)15/09/2014 08:49:00 - cduve (10.100.3.61)> 150 Opening data channel for file upload to server of "/dataportal/configuration.php"

(000611)15/09/2014 08:49:00 - cduve (10.100.3.61)> 550 can't access file.

(000611)15/09/2014 08:49:31 - cduve (10.100.3.61)> ABOR

(000611)15/09/2014 08:49:31 - cduve (10.100.3.61)> 226 ABOR command successful

(000611)15/09/2014 08:49:31 - cduve (10.100.3.61)> disconnected.

1

I suspect that you have Filezilla set up fine, based upon the logs you showed, and the issue is actually a directory or file permission issue.

Depending on the situation (meaning if this is safe to do or not), easiest way to test is to set the destination directory's (the one on the server) sharing and security to 'everyone' and then try again.

  • Hi Dave, I just tried that but no luck unfortunately although I did get an access denied popup for some of the files as it changed the permissions... Any other ideas? – doovers Sep 15 '14 at 8:54
  • Make sure you also selected Append in your screen shot. Are you saying the folder (e:\etc\www) has sharing and security set to everyone? Also, it looks like FileZilla is trying to find a file, not upload one... – Dave Sep 15 '14 at 9:03
  • 1
    Well after lots of trial and error I discovered the file I was trying to update was read only. Thanks for the help. – doovers Sep 16 '14 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.