1

According to this answer there's a Move button in the location tab of the properties pane of the OneDrive folder.

Except there isn't:

No Move Button in OneDrive

I cannot enter a new path, because although it is a text box, it doesn't accept input (UX fail no. 1)

How do I move this folder?

Update

I happen to be the system administrator. There's no reference in GPO about OneDrive or SkyDrive. There is a reference in the GPO on the local computer, but the only options I got are these:

  • Save documents to OneDrive by default
  • Prevent the usage of OneDrive for file storage
  • Prevent OneDrive files from syncing over metered connections

Local Group Policy Editor OneDrive options

3
  • This computer on a domain by chance? Because the answer I wrote still works for me. You are using Windows 8.1 Update 1 correct?
    – Ramhound
    Sep 15, 2014 at 17:13
  • Yep, it is in a domain
    – jao
    Sep 15, 2014 at 17:23
  • 2
    Ask your domain administrator for assistance. I wouldn't be shocked If there was a group policy that disabled the ability to move this profile folder.
    – Ramhound
    Sep 15, 2014 at 17:35

2 Answers 2

1

The "Prevent User from Manually redirecting Profile Folder" under User Configuration -> Administrative Templates -> Desktop in Group Policy prevents all the special folders for a user from being moved.

If there is no domain or local Group Policy change, there are also two registry keys called "DisablePersonalDirChange" located in these spots:

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer

As per the screenshots at SevenForum, the UI changes in the same way, in that it shows you the location, but removes the buttons for changing the location.

It's possible that your domain administrator has enabled Roaming Profiles or has another reason for not wanting your profiles moved.

3
  • So, I cannot move this folder as long as 'Prevent user from manually redirecting profile folder' is enabled?
    – jao
    Sep 16, 2014 at 11:20
  • Disabled the blocking policy, then moved the folder and enabled the policy.
    – jao
    Sep 18, 2014 at 15:49
  • Excellent, glad it worked!
    – cathoo
    Sep 19, 2014 at 10:22
0

If you are scared to edit the Registry, you can also do the following:

  • Uninstall OneDrive
  • Decide where you want the new OneDrive location to be
  • Create a folder called OneDrive inside that location if it does not exist already
  • Move all your files to the new OneDrive location
  • Install OneDrive again
  • When you are suggested where to create the OneDrive location, click on the Change button
  • When OneDrive says the location already exists, ignore and continue

OneDrive will likely re-download all the files again due to its poor sync algorithm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .