0

I want users in group Audio to have read/write and all of the other users (guest, anonymous, everyone....) to be able to browse and read only access to the same share folder. Guest users cannot mount the shared point in windows. Audio group is fine. Can you please correct what is wrong with my smb.conf?

 [global]
 writeable = yes
 path = /mnt/DANAS1/Audio
 default = Audio
 write list = @Audio
 workgroup = WORKGROUP
 os level = 20
 comment = CBN Audio NAS1
 map to guest = bad user
 valid users = audio,eng,vj,@Audio
 create mode = 765
 security = user
 directory mode = 765

[AudioNAS]
 comment = VBDAWAudio
 path = /mnt/DANAS1/Audio 
 available = yes 
 browsable = yes 
 public = yes 
 writable = yes 
 guest ok = yes
 read only = guest
 nobody printable = no
 locking = no strict
 locking = no
 share modes = yes
 create mask = 0755
0

A mechanism you could use is manage the permissions on the actual files/folders. So you have have a single share of something like:

 [global]
 writeable = yes
 path = /mnt/DANAS1/Audio
 default = Audio
 write list = @Audio
 workgroup = WORKGROUP
 os level = 20
 comment = CBN Audio NAS1
 map to guest = bad user
 valid users = audio,eng,vj,@Audio
 Guest ok = yest
 create mode = 764
 security = user
 directory mode = 764

Obviously the above will need your own flavor putting in since I don't know your plan for the rest of the share. With the files/folders in your share you set the group owner to audio (or whatever they are called) and set all permissions using chmod 764 (or something similar). This will allow:

File owner - Read, Write and Execute
Group - Read and Write
Other - Read

Don't think there is any reason why this sort of method wouldn't work for you.

  • Thanks Matthew... I see you added Guest ok = yes and changed modes to 764 in [global] section. (btw I read somewhere it needs 765 because execute permission is needed for the user to go up/down the path) That did not work. The thing is I want to apply these permissions (read only for guest and r/w for Audio group) to the shared directory with ALL OF THE SUBDIRECTORIES. As of now the whole shared tree is chowned to audio:Audio (and i feel there may be a problem). SElinux is disabled. – vjeko sa Sep 16 '14 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.