I have the exact opposite problem as this question, so the answer isn't applicable. For some reason, I can connect to the internet via Firefox on one of my computers, but I cannot connect to the internet via Internet Explorer or Google Chrome.

The computer is connected via an internal wireless adapter, and I can connect using IE/Chrome fine on the computer with a hard line to the router. I have another wireless computer using an external D-Link wireless adapter that I did not think to test last night, but I will tonight.

The page that appears in both browsers is Server not found, so I assumed it might be DNS-related. I've tried doing several ipconfig commands on the computer in question, such as /flushdns and /renew, but neither of them had the desired result of fixing the internet.

  • Do you have a proxy configured on Firefox? Try checking the options, it's under Advanced -> Network -> Connection -> Settings. – unlink Sep 16 '14 at 15:12
up vote 9 down vote accepted

IE and Google Chrome adopt the internet settings of the system, unlike Firefox which has its own connection settings option you can configure. One of the reasons why I prefer Firefox over other internet browsers.

You should check Internet Options setting in Control Panel. If your Firefox is working fine then there's definitely something wrong there.

You can also try to change your DNS servers manually. Here's a complete guide for that. You can use Public DNS Servers like Google's for example which are 8.8.8.8 and 8.8.4.4. Hope it works out for you.

  • I have Google DNS set on my personal computer, and IIRC it was set to the default gateway on this one. Turns out it was something awry in the BitDefender firewall daemon. Eventually Firefox stopped working as well, but once I turned the firewall off and back on, the internet worked again. Accepted answer because this would have been worth trying. – NobleUplift Sep 19 '14 at 17:30

Check your proxy sever settings in IE for your Internet setting. Make sure it's blank. Also, couldn't hurt to run a malware scan...

I had these symptoms in Windows 7 after Fiddler crashed. In 7, the Internet Options are tools (gear) menu, not Control Panel.

Since I don't use MSIE much, I just reset it, and MSIE and Chrome started working.

MSIE → Tools Menu → Internet Options → Advanced → Reset ... → Default Options (You do not need to delete personal info)

I had the same problem and it got resolved as follows.

  1. Press Win key + R.

  2. Type services.msc and enter.

  3. Services Window will open.

  4. Look for the service "Windows Event Log".

  5. Right click on it and choose restart.

  6. If it brings the "Restart other Services" Dialog box, Press yes.

  7. If this resolved your problem, Right click on the Service "Windows Event Log" again and choose properties and make sure you have "Startup type" set to Automatic.

  1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue.

  2. Type netsh winsock reset at the command prompt, and then press ENTER.

Note If the command is typed incorrectly, you will receive an error message. Type the command again. When the command is completed successfully, a confirmation appears, followed by a new command prompt. Then, go to step 3.

  1. Type exit, and then press ENTER. You should be prompted to reboot, if not you should reboot and test.

Check your network properties and see whether there are any additional DNS settings appended on the DNS tab. Remove them if so.

  • Welcome to Super User! This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill Aug 17 '15 at 10:43

if any of the above method does not work then simply go to connection setting of internet explorer or google chrome and untick the automatic detect setting or any other option then it will surely work

protected by Community Jul 10 at 20:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.