I'm trying to repair a friend's Dell Inspiron 620. It has Windows 7 Home Premium (x32), and we'd like to install Windows 8.1, if possible. However, no matter what I do, it gets stuck in the middle of loading. I've tried using the built-in startup repair, booting into safe mode, booting into a Win7 iso running on a flash drive, and booting into the Win8.1 DVD. They all stall mid-load, usually on the black screen with the Windows logo. The spinning icon or the animated bar freeze. When trying to boot into Safe Mode, it stalls on "classpnp.sys"

I've run hard drive and memory tests, both with the internal diagnostic tools, and DOS-based ones via flash drive. I've also blown out the case with compressed air.

I've completely run out of ideas.

  • Remove hardware and get it down to the bare minimums required. Try different RAM sticks (one at a time), you ma yalso want to try with another (known-good) power supply. Also Windows makes installation logs you may be able to check to narrow down where it's stopping. Sep 16, 2014 at 16:29
  • I removed pretty much everything shortly after I started working on it. I just tried each of the RAM sticks individually, and that didn't change anything. Unfortunately, I don't currently have access to any spare parts, power supply and additional RAM sticks included. Well... I suppose I could cannibalize my parents' PC, but I imagine they wouldn't be too pleased with that. I'll save it as a last resort. Sep 16, 2014 at 16:41
  • Then you'll need to get some, or take it to a pro who has them. But first, maybe a little clarification will help... Is it only getting "stuck" when trying to install Windows 8.1? Like can you actually get into Windows 7 successfully still? Do booting to the start-up repair, and Safe Mode get "stuck" to? Sep 16, 2014 at 16:44
  • Yes, they all get stuck, can't boot into Win7 at all. It's currently stuck at "Loaded: \Windows\system32\drivers\CLASSPNP.SYS", from when I tried to boot into Safe Mode Sep 16, 2014 at 16:49
  • This is most likely a RAM problem. The memory tests came back with no errors? Is this the same memory that has always been in it?
    – user142485
    Sep 16, 2014 at 18:48

1 Answer 1


Reboot the computer and press either del or escape on your keyboard upon the BIOS posting.

When launched into the BIOS, navigate to "Load Defaults" and then save, exit and reboot the system.

Alternatively, you could follow these steps from Dell.

If the above fails I would suggest replacing the HDD. If replacement of the HDD still presents the same problem; try finding another GPU (graphics card) to swap out the existing one with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.