0

Normally you can't make a folder with /\:*<>"? in its name. and also you can't name a folder CON,LPT1 and .... and also you can't have two folder with equal name in a single directory.

I THINK I found a way to break all the above rules!

You just need to build a New String in the below path of registry : HKCU\Software\Microsoft\Windows\ShellNoRoam\MUICache

And name it @WhatEverYouWant (For example @x). Then set its value the name that you want to have for your directory! (For example CON,LPT1,\/?:*<>| and so on).

enter image description here

Then close the registry and create a new folder. it name the @x (The name that you selected for the string before) and hit enter. the name automatically change to the value of the string that you already created in Registy.

If you create a new folder again in the same path and set its name to @x again, you will have the second folder with the same name!

enter image description here

The above way works fine in Windows XP. I want to know if this is a bug or it is a feature? And what is the equivalent way in Windows-7?

Update:

This is output of dir command (When I was created just two con folder on desktop) : enter image description here

  • Could you please CD to one of directories you have created and post a screenshot or the output of DIR command – Art Gertner Sep 17 '14 at 7:48
  • @smc I checked it already. In DIR command, they have shown as New Folder, New folder - Copy,New folder - Copy (2) and so on! – TheGoodUser Sep 17 '14 at 7:50
  • 1
    ... which means you haven't actually created a folder called CON, LPT or /\:*<>"?. What you see on your desktop is just an alias name, but not the name of the folder – Art Gertner Sep 17 '14 at 7:54
  • @smc Is it possible to do it in Windows-7 ? – TheGoodUser Sep 17 '14 at 7:59
  • Sorry, I don't have windows 7, I am running XP at the moment. Lets wait and see, maybe someone else on SU will find time to test it for you. May I ask, what is the practical purpose of this? – Art Gertner Sep 17 '14 at 8:10
1

As you can see from the output of your Dir command, you haven't really changed the filename. What's actually happening behind the scenes is that you are modifying your desktop.ini (a hidden, protected operating system file) file to display the string you defined in the registry, instead of the real directory name.

This is part of a feature to allow the localization of directory names (so you can display a different name depending on the user interface language) I don't know why Microsoft chose to make the behavior so easily accessible from Explorer, rather than requiring manual editing of the desktop.ini file though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.