3

I have been having issues with my computer waking up from sleep. It seems like after the computer sleeps for “a long time” (tends to be overnight) it crashes with a KERNEL_STACK_INPAGE_ERROR, which according to the crash dump was “Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+1ecfd )”. My computer was fine until I experimented with Linux’s Xen server. My experimenting required the addition of a spare video card and modification of bois settings. After I finished my experimentation, I reset the bios to the optimized defaults and reinstalled Windows (from an image I had made when I originally set up the computer) and it would no longer wake up from sleep. My hardware:

Mobo: Asus M5A99FX Pro R2.0

CPU: AMD FX-8320 Eight-Core Processor

Memory: 1 KHX1600C10D3B/8G module, 1/2 KVR 1333D3N9K2/4G kit for a total of 10GB

Graphics Card: AMD Radeon HD 6700

HDD: Seagate Hybrid Drive ST1000DX001

Operating System: Windows 8.1 Pro x64

What I Have Tried:

  1. Resetting the bios
  2. Installing all the drivers for the Mobo and Graphics card
  3. Replaced the HDD (the SMART claimed that it had gone bad)
  4. Replaced SATA cable attached the HDD
  5. Ran MemTest86+ for 12 hours
  6. Stress tested the Graphics card and CPU
  7. Fresh install of Windows
  8. Replaced video card with a spare video card
  9. Upgraded the BIOS

More relevant information:

Event log entries:

  1. “The AODDriver4.3 service failed to start due to the following error: The system cannot find the file specified.”
  2. “The system firmware has changed the processor's memory type range registers (MTRRs) across a sleep state transition (S4). This can result in reduced resume performance.”

An Error which occurred on resume of sleep:

“The instruction at 0x00007FFA4AD167D5 referenced memory at 0x00007FFA226C40100. The required data was not placed into memory because of an I/O error status of 0xc000000e.”

Memory.dmp Results (I can post the dump itself if anyone is interested):

Microsoft (R) Windows Debugger Version 6.3.9600.17237 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Bitmap Dump File: Only kernel address space is available


************* Symbol Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       symsrv*symsrv.dll*c:\localsymbols*http://msdl.microsoft.com/download/symbols
Symbol search path is: symsrv*symsrv.dll*c:\localsymbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 8 Kernel Version 9600 MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 9600.17085.amd64fre.winblue_gdr.140330-1035
Machine Name:
Kernel base = 0xfffff803`ee418000 PsLoadedModuleList = 0xfffff803`ee6e22d0
Debug session time: Wed Sep 17 11:14:48.743 2014 (UTC - 7:00)
System Uptime: 0 days 14:57:00.106
Loading Kernel Symbols
...............................................................
................................................................
.......................................
Loading User Symbols
PEB is paged out (Peb.Ldr = 00007ff5`ffffd018).  Type ".hh dbgerr001" for details
Loading unloaded module list
........................
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 7A, {fffff6fac0080000, ffffffffc00000c0, adcc2880, fffff58010000000}

Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+1ecfd )

Followup: MachineOwner
---------

7: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KERNEL_DATA_INPAGE_ERROR (7a)
The requested page of kernel data could not be read in.  Typically caused by
a bad block in the paging file or disk controller error. Also see
KERNEL_STACK_INPAGE_ERROR.
If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
it means the disk subsystem has experienced a failure.
If the error status is 0xC000009A, then it means the request failed because
a filesystem failed to make forward progress.
Arguments:
Arg1: fffff6fac0080000, lock type that was held (value 1,2,3, or PTE address)
Arg2: ffffffffc00000c0, error status (normally i/o status code)
Arg3: 00000000adcc2880, current process (virtual address for lock type 3, or PTE)
Arg4: fffff58010000000, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)

Debugging Details:
------------------


ERROR_CODE: (NTSTATUS) 0xc00000c0 - This device does not exist.

BUGCHECK_STR:  0x7a_c00000c0

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  RtkNGUI64.exe

CURRENT_IRQL:  0

ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) amd64fre

TRAP_FRAME:  ffffd0011f6b34f0 -- (.trap 0xffffd0011f6b34f0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=0000000000000001
rdx=fffff580108042e8 rsi=0000000000000000 rdi=0000000000000000
rip=fffff803ee816924 rsp=ffffd0011f6b3680 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000000 r10=fffff58010000000
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
nt!MiCommitPageTablesForVad+0x1c0:
fffff803`ee816924 410fa302        bt      dword ptr [r10],eax ds:fffff580`10000000=00000000
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff803ee59b1ad to fffff803ee56bfa0

STACK_TEXT:  
ffffd001`1f6b31f8 fffff803`ee59b1ad : 00000000`0000007a fffff6fa`c0080000 ffffffff`c00000c0 00000000`adcc2880 : nt!KeBugCheckEx
ffffd001`1f6b3200 fffff803`ee4a05f8 : 00000000`00000002 ffffd001`1f6b3368 ffffe001`2e329a98 ffffd001`00000000 : nt! ?? ::FNODOBFM::`string'+0x1ecfd
ffffd001`1f6b32f0 fffff803`ee47f5f5 : ffffe001`2ed03080 ffffe001`2e329a98 00000000`c0033333 fffff803`00000000 : nt!MiIssueHardFault+0x184
ffffd001`1f6b33b0 fffff803`ee57622f : 00000000`00000000 00000000`00000000 00000000`00000000 ffffd001`1f6b34f0 : nt!MmAccessFault+0x3d5
ffffd001`1f6b34f0 fffff803`ee816924 : 00000000`00000000 00000000`00000000 00000000`00000000 fffff803`eeba769a : nt!KiPageFault+0x12f
ffffd001`1f6b3680 fffff803`ee486ed4 : fffff6fa`c0080000 00000000`00000001 00000000`00000001 00000000`00000001 : nt!MiCommitPageTablesForVad+0x1c0
ffffd001`1f6b36f0 fffff803`ee81563c : ffffe001`2effa1b0 00000000`00000001 ffffd001`1f6b3b00 00000000`00000004 : nt!MiCommitExistingVad+0x314
ffffd001`1f6b3810 fffff803`ee5777b3 : ffffe001`2ed03080 00000000`0013fdf8 ffffd001`1f6b3a28 00000001`401dd250 : nt!NtAllocateVirtualMemory+0x46c
ffffd001`1f6b3a10 00007ffd`e84717fa : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0013e9a8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00007ffd`e84717fa


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt! ?? ::FNODOBFM::`string'+1ecfd
fffff803`ee59b1ad cc              int     3

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+1ecfd

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  53388e13

BUCKET_ID_FUNC_OFFSET:  1ecfd

FAILURE_BUCKET_ID:  0x7a_c00000c0_nt!_??_::FNODOBFM::_string_

BUCKET_ID:  0x7a_c00000c0_nt!_??_::FNODOBFM::_string_

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:0x7a_c00000c0_nt!_??_::fnodobfm::_string_

FAILURE_ID_HASH:  {90f07b7f-b6ca-d03a-b3d4-2f5aff8f8644}

Followup: MachineOwner
---------
2

I know this post is older, but thought I would post the fix/workaround that I found since I recently purchased a ASUS M5A99FX PRO R2.0 and was running into the same exact issue with BSOD when waking from sleep.

The cause here is the ASmedia SATA Controller that is enabled by default onboard. At first, I had my main SSD Sata boot drive connected to the blue SATA controllers on the motherboard which are the 2 ASmedia SATA controllers. Via process of elimination, I finally decided to MOVE my main SSD boot drive to the other white colored SATA ports (AMD SB Controller) and I completely disabled the ASmedia chip in the bios. My computer wakes up from sleep without any issues now. Therefore, unless you have a need for more than 5 SATA ports which the AMD SB950 SB Controller support, there is not much loss here. I am still annoyed that there are no driver or BIOS updates to fix this (when you purchase something, all components should work properly!) but overall it doesn't affect my setup.

I hope this helps someone else who's at wit's end trying to figure out why thier ASUS M5A99FX PRO R2.0 setup is BSOD when waking up from sleep mode!

0

Looks to me like the problem lies within RtkNGUI64.exe. I have a custom built computer with an ROG Crosshair V Formula-Z mobo and ASUS Radeon R9 290 graphics card and I've had some issues with my computer waking from sleep and showing nothing but a black screen until I hit ctrl+alt+del. Then once the lock screen shows up, I just hit cancel and my desktop will reappear. However, my main audio device is missing afterwards. Headphone jack/front panel still works but the main audio device simply disappears from my system until I restart. I checked some of my crash dumps and came up with a common executable... RtkNGUI64.exe.

  • How did you end up resolving this issue? – Chris Crutchfield Sep 18 '14 at 5:04
  • Unfortunately I haven't yet been able to fix this. I've tried updating my drivers and rolling them back and neither has done anything. I hope the team at Realtek will release an update soon because this is becoming a very frustrating issue. – Aaron Chapman Sep 18 '14 at 18:26
  • It almost makes me wonder if it's my chipset drivers rather than my audio drivers because I've had a very noticeable audio lag when watching videos/movies. I've run a DPC latency checker and it is consistently above the red line. – Aaron Chapman Sep 18 '14 at 18:31
0

The error code c00000c0 you see in parameter 2 means that Windows failed to detect the drive (STATUS_DEVICE_DOES_NOT_EXIST):

C:\Users\André>err c00000c0
# for hex 0xc00000c0 / decimal -1073741632
  STATUS_DEVICE_DOES_NOT_EXIST                                   ntstatus.h
# This device does not exist.
# as an HRESULT: Severity: FAILURE (1), FACILITY_NULL (0x0), Code 0xc0
# for hex 0xc0 / decimal 192
  ERROR_EXE_MARKED_INVALID                                       winerror.h
# The operating system cannot run %1.
# 2 matches found for "c00000c0"

Update the firmware/softwwre for your Seagate Hybrid Drive. Also run a HDD diag tool from Seagate to make sure the drive is fine.

  • I just ran SeaTools on it and it failed the "Short Drive Self Test" but has currently passed the "Short Generic Test". Is this a sign that the drive might be bad? – Chris Crutchfield Sep 18 '14 at 5:03
  • maybe. Also run this tool: crystalmark.info/software/CrystalDiskInfo/index-e.html Does it show any warnings? – magicandre1981 Sep 18 '14 at 16:06
  • It did not show any warnings. I ended up moving the HDD to a different SATA controller. After doing so, I reran the Short Drive Self Test and it passed this time. I've been a couple of days without any crashes. I will report back in a week. – Chris Crutchfield Sep 20 '14 at 17:00
  • ok, looks like the SATA port had an issue. – magicandre1981 Sep 21 '14 at 7:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.