0

I noticed rather annoying behavior in gvim which relates to changing my Linux distro to openSUSE. When switching from insert to normal mode (hitting ESC) the cursor needs at least second! to become normal mode wide cursor even though insert mode indicator --INSERT-- dissapears immediately. Going from normal to insert mode is ok and the cursor becomes "thin" cursor immediately.

What can be the cause?

3

It's waiting for any other input, as there are key mappings that begin with an escape. Vim needs to distinguish a lone escape from an escape followed by the rest of a function key etc.

You can change the timeout with e.g. :set ttimeoutlen=10. See :help timeout for more info.

2
  • I already read about this and it does not work for me. Also it does not explain why `--INSERT``1 dissapears almost immediately (and I have feeling it really does enter normal mode and just the appearance of the cursor lags behind).
    – ps-aux
    Sep 18 '14 at 17:27
  • I did some investigation inspired by your advice and found out that the problem is really <Esc> timeout. But the correct setting was :set tm=10 as that is the value taken into consideration at least in my case.
    – ps-aux
    Sep 20 '14 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.