0

I'm having a bit of trouble with one of my Windows 7 Professional 64-bit w/ SP1 computers browsing the internet. I use the computer as a bed for testing different applications and so forth. The history is this : I had tested out some internet cafe programs a month or so ago. None of them worked as stated or desired, so I ended up uninstalling them from the system. Since then, I can't browse the internet with the latest versions of Chrome, Firefox, Safari, Internet Explorer, or even Lynx.

I've done practically everything from my own experience or that I've found in other articles or forums where people have similar issues. Here's a list of what works and what I've tried:

  • I can successfully ping/tracert/nslookup any IP address or domain name.
  • I can successfully browse the internet using the browsers listed above if I directly type the IP address
  • I can successfully connect to the problematic computer remotely via Remote Desktop and GoToAssist.
  • I can successfully browse the local workgroup network and connect to other network shares.
  • I've checked the proxy settings for the computer and no proxy is set.
  • I've scanned the computer for viruses/malware (clean).
  • I've repaired WinSock/TCPIP, cleared all proxy/VPN settings, and repaired the Windows Firewall, along with using the rest of the tools available with the NetAdapter Repair All-In-One v1.2 utility (including resetting the DNS servers, flushing the DNS cache, etc., etc.).
  • I've uninstalled the network drivers, downloaded the very latest (Realtek GBe) drivers, and reinstalled the NIC.
  • I've repaired a problem found in Winsock 2 using LSP-Fix (I was excited and thought this was the fix, but alas it didn't affect the problem). Running LSP-Fix afterwards shows "No problems found".
  • I've ran WinMRT and it successfully resolves hostnames and performs the tracert with no problem.
  • I've monitored the TCP traffic using TCPView and Wireshark, but I didn't notice anything in either log.
  • I've imported the registry settings for HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ from a working computer to no affect.
  • I've logged into the computer as a separate user and have the same internet browsing problem in all browsers listed above.

In addition to the list above, the only thing that has allowed me to browse the internet in a web browser has been to install the Tor bundle and use the TorBrowser. Additionally, some other applications (such as Dropbox) will not connect to the internet.

I've looked and had thought about attempting a system restore, but unfortunately have no restore points that are listed before installing the cyber cafe software. I have not attempted a Windows repair installation or a full format and reinstall as the system is in perfect working order other than this particular problem (and I would prefer not to have to reinstall).

I'm to the point now where I could use some assistance, so that's why I'm posting here on SuperUser and on Experts-Exchange. I do not have any desire to give up on the problem and just reinstall, so any help would be greatly appreciated.

Thanks, Justin

  • Do you have any 3rd party firewall software installed? Sounds like an outbound filtering rule gone wrong to me. Alternatively, can you use software that isn't a browser (e.g. telnet) to connect to HTTP servers? – Jules Sep 18 '14 at 23:22
  • In case you're unfamiliar with using telnet for HTTP: support.microsoft.com/kb/279466 – Jules Sep 18 '14 at 23:24
  • Have you scanned for rootkits/malware/etc? – DavidPostill Sep 19 '14 at 7:15
  • @Jules No, there is no third-party firewall installed. As I mentioned we can connect to any HTTP servers just fine when using an IP address, just not with domain name. I went ahead and attempted the telnet connection like you had suggested, but I can't connect to any website like that regardless of whether or not I use my broken computer or my working computer. It does resolve the host and starts the connection though - it just states that the connection is lost afterwards and I'm not able to enter any GET commands. – Justin Sep 19 '14 at 16:28
  • @DavidPostill As I mentioned in my post, I have scanned the system and it is clean. FYI - I've ran RKill (prior to the other scans), Malwarebytes Anti-Malware, Malwarebytes Anti-Rootkit, Avast Free Antivirus, JRT, Adwcleaner, Kaspersky TDSSKiller, SuperAntiSpyware, and ComboFix. Also, as a note, I've performed a clean diagnostic boot with msconfig as well as booting into Safe Mode with Networking, but I have the same problems either way. – Justin Sep 19 '14 at 16:31
0

Unfortunately, since I didn't receive much help here at SuperUser (and only a few comments on Experts-Exchange), I ended up just performing a repair installation (or in-place upgrade...whatever you like to label it). That has corrected the browsing issue, though I really wanted to learn and fix the problem itself. Oh well...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.