3

I'm working on a company PC that was used previously by someone else. I don't find that AutoHotKey is installed on this machine.

The Ctrl and Alt keys are swapped - (when I press Ctrlit behaves like I pressed Altand vice-versa). There is no AutoHotKey installed (if you could think it causes the problem).

How can I swap the keys back in the "native way"?

  • 3
    Are you using their old user account, or is this a new one made just for you? Are the keys actually in the expected place on the keyboard (ie: somebody didn't just swap key caps did they)? Have you confirmed the language, keyboard and region settings are set to correctly match your region and hardware? Do they work as expected while in Safe Mode? – Ƭᴇcʜιᴇ007 Sep 19 '14 at 16:48
  • this is not so useful, CRTL and ALT are standard keys in all languages so this 'swapping' has its 'roots' deeper than the reason you're exposing – diras2010 Sep 19 '14 at 16:53
  • @ Ƭᴇcʜιᴇ007, I'm using a new user account, but the system was installed and used before me. Keys are actually in the expected place. Keyboard and region settings look right. I will check it in Safe Mode and in BIOS as @user370244 suggested. – nightcoder Sep 19 '14 at 17:01
  • Couldn't boot in Safe Mode for now, it seems like it's disabled by our support stuff.. – nightcoder Sep 19 '14 at 18:45
  • Just to clarify, I meant that it seems Safe Mode is disabled by our support stuff. – nightcoder Sep 19 '14 at 18:52
8

According to ( http://www.howtogeek.com/howto/windows-vista/disable-caps-lock-key-in-windows-vista/ ) it's possible to remap keys by editing the registry. Perhaps the previous user of your computer has done so, making the two keys point to each other? To check do the following:

  1. In the start menu type "regedit", it will appear in the search results, and then run it.
  2. Navigate to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout".
  3. Look for an entry called "Scancode Map".

If you don't see a key called "Scancode Map" then this isn't the problem. Perhaps you should check the Windows Add/Remove software section and see what else they've installed (as there are programs other than AutoHotKey out there).

Entry Present

If you do see the "Scancode Map" entry then some of your keys are being remapped.

Entry Not Present

In my test this entry was not present on a clean Windows installation, and so I would assume it's not needed for regular functions (but there could be other variables unknown).

I would not advise deleting it unless you've examined the contents, even then it's really something that IT should handle. You mentioned having support staff so I assume you are in a work environment so it's possible IT has other additional keys being remapped intentionally that you wouldn't want to delete.

Unfortunetly I don't know enough about this subject to assist you in examining the key's data to determine specifically which keys are being remapped. The previously linked article is also rather brief on the subject, and does not list the codes equating to the alt or control keys.

  • Some Scancode info: superuser.com/questions/700110/… – Robin Hood Sep 19 '14 at 19:41
  • 2
    I had that registry key, I deleted it and restarted Windows, after that, the keyboard keys are back to their normal! Thanks! – nightcoder Sep 19 '14 at 19:52
  • 1
    @nightcoder beware, just nuking that key might have other unforeseen consequences. I hope you made a registry backup, just in case... – corsiKa Sep 19 '14 at 20:36
  • @corsiKa, yep, I exported the key before deleting it, thanks for the warning. – nightcoder Sep 19 '14 at 21:04
2

Check the setting in the bios keyboard section, called swap alt ctrl or similar. It's one possible location for this behaviour.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Jan Doggen Sep 19 '14 at 17:32
  • Haven't found any keyboard settings in the BIOS, but thanks! – nightcoder Sep 19 '14 at 18:43
  • 1
    @JanDoggen This may not solve the OP's problem, but it's a valid suggestion. imgur.com/DMntmdF – Robin Hood Sep 19 '14 at 18:51
  • 1
    If some PCs have these settings in BIOS then yes, it's an absolutely valid suggestion. – nightcoder Sep 19 '14 at 18:53
1

if you can access the device manager you can 'uninstall' the current keyboard and then do a restart, the system will recognize the keyboard as a new device and reinstall the default driver for it, to make sure this trick to work, uninstall the keyboard, shut down the pc, swap the keyboard with another device (if it's an USB), then restart the pc

if you can't access the device manager (due admin/user privileges), go and talk with the IT maintenance guys and explain your problem to them, they are in the obligation of fixing it

  • Uninstalling didn't help :(, but thanks! – nightcoder Sep 19 '14 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.