0

I have just bought a brand new computer in parts. I assembled it and tried it, but it is not booting.

Parts:

  • Intel Core i5-4590
  • 2 x 4GB of Kingston HyperX Genesis RAM
  • Gigabyte Z87-DS3H
  • Asus nVidia GeForce GTX 770 (disconnected, no effect)
  • Corsair CX750
  • WD Green 2TB (disconnected, no effect)
  • Antec Three Hundred Two

First when we tried to boot the fans and drives turned on for maybe 2 seconds, then everything turned off for a couple of seconds, and then the cycle restarted.

We tried using the motherboard's CMOS reset switch; when the switch is disconnected everything seems to turn on, but nothing actually happens (same fans & drives on effect). But now, the power switch just turns everything on for half a second and then off again.

The case does not have a speaker, so I am not able to hear any beep codes.

What should I try to fix this?

  • Try replacement parts. Welcome to computer building, you need spares. – Ƭᴇcʜιᴇ007 Sep 20 '14 at 14:42
2

Your motherboard may require BIOS update to support this CPU.

i5-4590 is a 4th generation Core CPU (first digit in the 4-digit model name, 3-digit models are 1st gen). 4th gen support was added in F2 BIOS (source: BIOS download page). If your motherboard doesn't have F2 or F3 BIOS, then it won't start properly with 4th gen CPUs.

If that's the case then you have to get a 3rd gen or older CPU for this socket, install it and flash latest BIOS. Unfortunately there's no way to determine if it's the old BIOS that causes this issue - checking BIOS version is possible only after booting.

| improve this answer | |
  • Tried assembling a friend's computer, an identical mobo worked first try with an i5-4570. – PurkkaKoodari Sep 20 '14 at 10:11
  • Well, your answer was actually the solution. I personally find it weird that a 4590 doesn't work while a 4570 does. – PurkkaKoodari Sep 29 '14 at 12:10
0

First of all you should re-check all the cable and hardware connections in the PC and also I would suggest to try a different PSU. I encountered a similar problem when my graphics card was not mounted properly on the PCI express slot. Also as mentioned maybe a bios update would do the trick..

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.