I installed Ruby on WinXP. Used rubyinstaller-1.8.6-p383-rc1.exe.

Ran gem install rake

Get error:

Error installing rake: invalid gem format for C:/Ruby/lib/ruby/gems/1.8/cache/rake-0.8.7.gem

I've tried deleting the cache folder but i keep getting the same error. Tried with Ruby 1.9.1 too. Same error. What am i doing wrong?

  1. Manually download the Rails gem
  2. Unpack it with gem unpack rails-X.X.X.gem
  3. Search the Rakefile file inside the unpacked dir for lines that start with s.add_dependency
  4. Manually download all the dependencies at rubyforge (each one has its own project)
  5. Install each one with gem install xxx.gem. For Rails 2.0.1 the appropriate order is: activesupport, actionpack, actionmailer, activerecord, actionresource, rake, rails.

And whenever you have an issue with gem, trying updating it first: gem update --system. That usually solves many problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.