For some reason i can't access my external HDD anymore. It's not showing up in Finder, although i can see it in the Volumes folder and in Disk Utility app.

When i access the HDD from terminal and try to list the files via ls I get permission denied. I tried running

sudo chmod 755 myHDD

now ls returns nothing at all, like an empty folder. At this point I figured the first step is to try to unmount it correctly, which i tried in various ways:

Via Disk Utility: Failed and wants me to make sure nothing is in use on the HDD.

In terminal i tried these methods:

diskutil unmountDisk force myHDD

"Unmount Failed"

sudo umount /dev/disk1

"umount: /dev/disk1 not currently mounted", but it still exists in Volumes/myHDD

hdiutil detach /dev/disk1

"hdiutil: detach: timeout for DiskArbitration expired"

hdiutil eject /dev/disk1

"hdiutil: detach: timeout for DiskArbitration expired"

As you can see nothing is working for me. I can't unmount it, and when i unplug it form the computer it persists in Disk Utility.

All helps and tips are greatly appreciated!


Tried with to repair the disk from Disk Utility with Tuxera NTFS and got this error message:

Tuxera NTFS could not mount /dev/disk2s1 at /Volumes/VERBATIM HD because the following problem occurred:

Aligned I/O enabled. CBCIO enabled. WARNING: ReadFully - I/O error while reading from file (5: "Input/output error") WARNING: failed at: pread(3, 0x100580000, 282624, 17980981248); WARNING: bytesRead=0 ntfs_attr_pread_i: ntfs_pread failed: Input/output error Failed to read $UpCase, unexpected length (-1 != 131072). __ntfs_volume_release(): Inode 10 still have 1 references. Failed to mount '/dev/rdisk2s1': Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

1 Answer 1


It may be a problem with FileSystem

Are you using NTFS filesystem? Notice that OSX needs some special software to work with this FileSystem and I had some problems with it in the past.

If you are using NTFS, try to uninstall your NTFS software and install it again.

  • Thank you for the input. It is indeed NTFS filesystem, but the weird part is that it has been working for over a year, without external NTFS software (only readable though).
    – olof
    Sep 21, 2014 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .