1

this is driving me insane.

i am trying to download files using FTP. i tried with PHP's FTP, the FTP binary, WGET, none of them work. They all have the same problem. When get command is initiated, the client hangs and never completes or throws any errors. This only happens on Amazon EC2 instance (RHEL 7). This has previously worked on CentOS instance and also works locally on my Windows machine but for some reason does not work on Amazon's RHEL7 instance.

I have:

  • Opened ALL incoming/outgoing ports in Amazon security group
  • Disabled iptables and ip6tables.
  • Disabled SElinux.
  • Set 777 permission on the local target folder.
  • Running PHP/FTP/WGET using sudo.
  • Used passive or active mode ad nauseum.

The remote FTP file exists I know that for a fact. There is something, and I don't know what, that prevents THIS specific Amazon instance from initiating an FTP download. Has anyone ever encountered this before? It's driving me INSANE.

0

My best guess is the host isn't routable meaning it either doesn't have a public IP or there is some VPC configuration affecting the communication since you state wget doesn't work either.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.