2

Trying to install dahdi from the link. I have downloaded package for dahdi. But on doing

cd /usr/src/dahdi-linux-complete*
make && make install && make config

My terminal shows

[root@localhost dahdi-linux-complete-2.10.0+2.10.0]# make
make -C linux all
make[1]: Entering directory `/usr/src/dahdi-linux-complete-2.10.0+2.10.0/linux'
make -C drivers/dahdi/firmware firmware-loaders
make[2]: Entering directory `/usr/src/dahdi-linux-complete-2.10.0+2.10.0/linux/drivers/dahdi/firmware'
make[2]: Leaving directory `/usr/src/dahdi-linux-complete-2.10.0+2.10.0/linux/drivers/dahdi/firmware'
You do not appear to have the sources for the 2.6.32-431.29.2.el6.x86_64 kernel installed.
make[1]: *** [modules] Error 1
make[1]: Leaving directory `/usr/src/dahdi-linux-complete-2.10.0+2.10.0/linux'
make: *** [all] Error 2

output of uname -r

[root@localhost dahdi-linux-complete-2.10.0+2.10.0]# uname -r
 2.6.32-431.29.2.el6.x86_64

I have the kernel source then why its showing the message You do not appear to have the sources for the 2.6.32-431.29.2.el6.x86_64 kernel installed.

I know this question is asked many times.I have tried those but dint resolve this problem. I have tryed updating my system but it says nothing to update.

Any Suggestions apart from reinstalling my OS???

1

Sure this described everywhere. If you not want read, try this:

yum update -y
yum install kernel-devel -y
reboot
  • tryed that,it says nothing to do already updated that package – deogratias Sep 23 '14 at 4:47
  • try reinstall kernel-devel – arheops Sep 23 '14 at 17:01
  • And make sure you reboot so that you're running the kernel that you installed the kernel-devel tools for (or run sudo yum install kernel-devel-$(uname -r) ) – sruffell Sep 23 '14 at 17:04
  • 1
    solved it, removed all kernel packages by yum remove kernel* and then reinstalling by yum install kernel* – deogratias Sep 25 '14 at 4:57
0

I have reviewed the source and found that it looks a different location .

First run

yum install kernel-devel
reboot

And here is the trick

ln -s /usr/src/linux /usr/src/kernels/`uname -r`

For example in my server

[root@freepbx ~]# ls -l /usr/src

lrwxrwxrwx 1 root root 34 Jul 12 17:31 linux -> kernels/3.10.0-862.3.3.el7.x86_64/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.