3

I have installed VMware-workstation-full-10.0.3-1895310 on windows 8.1. Although VMware bridge protocol is enabled in my LAN adapter but still I am unable to add and switch VMNET0 to bridged mode.

It says

Cannot change network to bridged: There are no unbridged host network adapters

So far I have tried the following things:

  • I have reinstalled it many times.

  • I have restore default settings of virtual network editor.

  • Have also checked that Vmware bridge protocol is enabled.

  • Have checked that whether vmnet bridge service is running or not.

  • Have done almost everything present on forums.

I post images below and also I am posting in drop box check out drop box link of screen shots

enter image description here enter image description here enter image description here

4

restoring VMWare network setting to default from Virtual Network Editor Fixed my problem

see the more detailed answer with images at the below post https://superuser.com/a/1130121/57836

  • 1
    This worked for me after upgrading Windows 10 to 1703 (Creators Update) somehow seemed to have caused this to fail. – DeCaf Jun 15 '17 at 12:40
1

Steps:

  1. Uninstall Kaspersky
  2. Restart your PC
  3. Open the "Virtual Network Editor" (Edit > Virtual Network Editor)
  4. If there is no VMNET0 reinstall VMware otherwise reinstall Kaspersky
1

Removing Kaspersky Internet Security really works (Windows 8.1 + Kaspersky IS 15). Uninstall your anti-virus software (in case of Kaspersky IS you can keep your license data), reboot, install VMWare Workstation - Profit! :)

After that you can finely install Kaspersky IS.

1

after installing VMWare Workstation on a new machine I came across the above error which I’d never seen before – there were no currently-bridged adapters available to bind my virtual network to.

I believe the trigger was disabling the 2 automatically created virtual network adapters before I’d actually opened up a VM. The long and short of it os that the bridging kernel driver is not running, probably due to the fact that the vmware bridge protocol is not installed on the physical network adapter(s).

So:

Click on your network connections and choose “Open Network and Sharing Center” Open Network and Sharing Center

Open the properties for your NIC and check whether youhave the VMWare Bridge protocol installed Click on the properties button . Is the bridge protocol installed?

If not, add the service and choose “VMware ridge Protocol” from the next dialogue box. If there are no services to install then it is likely that your install is corrupted and a reinstallation

0

I too had problems with VMNET0 not working as bridged after upgrading to Windows 10. I am currently using VMWare Workstation 12. I was able to resolve this by going to control panel, opening programs and features, right-clicking on VMWare Workstation and selecting the Repair option. After the repair was completed (yes, it showed network drivers being removed/installed) a reboot was required and all is now good. VMNET0 working properly as bridged. I hope this helps.

-1

Export all your virtual machines to OVF. Uninstall VMWare. Install VirtualBox. Import virtual machines. This solved my problems after wasting several days and reading over 100 pages of "why bridged network does not work on VMWare".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.