3

After a repair task with disk utility I can't mount my external hard drive on my mac. I have tried to mount it on terminal

mount /dev/disk1s1

but I receive this eror

mount: /dev/disk1s1: unknown special file or file system.

I have tried to verify the volume

diskutil verifyVolume disk1s1

and I receive this error

Error starting file system verification for disk2s1 OneTouch4: Invalid request (-69886)

What I can do?

This is the result of diskutil list

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            499.4 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *500.1 GB   disk1
   1:               Windows_NTFS OneTouch4               500.1 GB   disk1s1
  • could you post the output of sudo fdisk -l – Art Gertner Sep 24 '14 at 9:38
  • fdisk: illegal option -- l – Davide Brognoli Sep 24 '14 at 17:25
  • sorry, didn't know that you are on Mac – Art Gertner Sep 24 '14 at 18:25
1

If you need access to your drive, there is commercial alternatives such as Paragon NTFS for Mac, or Tuxera NTFS for Mac.

I don't have much experience with either, but I believe them to be acceptable solutions.

If however, you feel in the experimental mood, there is unofficial NTFS support in macOS. However, no guarantee is provided.

| improve this answer | |
1

In the recent macOS, this command should work:

diskutil mount disk1s1

Where disk1s1 is the disk and partition number from diskutil list.

The volume will mount in read-only.

For the write access support, read: recommendations for reading and writing NTFS from macOS.

| improve this answer | |
  • I thought NTFS mounts automatically nowadays, but I can't test it now. – SPRBRN Oct 30 '17 at 11:58
0

It is NTFS, you cannot mount it. It must be Mac OS Journaled or FAT32.

| improve this answer | |
  • 1
    Strange. I mount another NTFS hard drive with command sudo mount -t ntfs /dev/disk2s1 /Volumes/VERBATIM/ and it work perfectly. – Davide Brognoli Sep 24 '14 at 18:36
  • That is surprising, as Apple say that Snow Leopard and up cannot mount an NTFS drive. Now I am on my Macbook, I can use links. NTFS3G (macntfs-3g.blogspot.co.uk) allows you to mount NTFS drives, format as NTFS etc. – EdG Sep 24 '14 at 18:40
  • I have Paragon NTFS installed on my machine and I can mount every NTFS disk. – Davide Brognoli Sep 24 '14 at 18:59
  • Should've mentioned that! Maybe the disk is corrupted then – EdG Sep 24 '14 at 19:06
0

You can mount any NTFS disk, natively. You simply can't write to it without additional 3rd party software. If you can't see the drive at all, or it won't mount, the drive is most likely beginning to fail/failing/failed.

| improve this answer | |
0

You don't need external program to mount NTFS volume, follow these steps to mount NTFS external disk on macOS. This is tested and working on macOS Mojave-

sudo mkdir /Volumes/MyNTFS
sudo mount -t ntfs -o rw <Disk Identifier> /Volumes/MyNTFS

To get disk identifier, you can run diskutil list. For example, if below is the output-

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk2
   1:       Microsoft Basic Data MyNTFS                  2.0 TB     disk2s1

Then you can run following command to mount-

sudo mount -t ntfs -o rw /dev/disk2 /Volumes/MyNTFS
| improve this answer | |
0

For those who are already using ntfs for mac by Paragon, and have faced the famous "Unable to mount" error,

try executing -

sudo kextunload /Library/Extensions/ufsd_NTFS.kext    // unloads driver

sudo kextload /Library/Extensions/ufsd_NTFS.kext      // reloads it

This is what worked for me.

However, if the issue persits, here's an article that might help - https://kb.paragon-software.com/article/406

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.