1

I am using Windows 7 and Windows 8 and I see the following behavior with Microsoft Office 2010.

Create two Excel files, say a.xls and b.xls

Open a.xls by double clicking it.

After the file is opened in Office 2010 Excel, modify this file and do not save.

Try opening b.xls. by double clicking on it.

b.xls never opens.

This behavior only happens on Windows for excel files on 2010.

It works fine with any other type of files (.doc, .docx, .ppt etc). It also works fine on Office 2011 and Office 2013.

Is there a workaround for this? Any patch etc?

Highly appreciate any insights.

Thanks!

  • 1
    I could not recreate your issue. b.xls opened fine for me. – Wutnaut Sep 24 '14 at 15:16
  • 1
    This also works. 2 workbooks are opened. If you want to Excel windows it requires launching Excel twice, dragging and dropping the file, into each window. – Ramhound Sep 24 '14 at 15:29
  • @Wutnaut Did you edit the first file without saving? And then open the second file? – Vink Sep 24 '14 at 17:02
  • Yes Vink, I opened a.xls and added some random info into random cells, then opened b.xls. – Wutnaut Sep 24 '14 at 18:15
  • Strange, I tried that on three different installations of Microsoft Office 2010 and found the same behavior. Which windows OS are you using? – Vink Sep 24 '14 at 19:09
1

This a minor Microsoft Office Excel 2010 and Excel 2013 bug.

The second XLS file is waiting for the first XLSX file to exit out of cell editing. Once you hit enter and leave cell editing mode, the second XLSX file opens.

There is no fix as far as I know since it existed in Office 2010 Excel and continues to exist in Office 2013 Excel. There's another discussion about not being able to open a second Excel spreadsheet here as well. Same conclusion.

You just have to press Enter (to leave cell editing mode) before you open the second Excel spreadsheet.

0

By default, Excel 2010 opens your b.xls in the same instance. So I would hold down the Shift key while double-clicking b.xls. This will launch a 2nd instance of Excel, which will work independently of what is happening in the 1st instance.

-3

Excel cannot be opened in two instances. All you need to do is open a.xls and then right click on Excel icon and open blank excel file and open b.xls. It will work

  • What? Excel can definitely have more than one instance. – Raystafarian Sep 24 '14 at 15:31
  • That's not true. Multiple instances of Excel 2010 can be opened on a computer and multiple Excel workbooks can be opened directly from Windows Explorer. – I say Reinstate Monica Sep 24 '14 at 15:31
  • It can be open multiple instances, sometimes it happens. I have faced same situation. in that case all you need to do is open another excel manually. We have had that situation and it solved problem. – Keyur Shah Sep 24 '14 at 15:49
  • 1
    @KeyurShah may be referring to "ignore DDE" option in Advanced. If you "uncheck" the option, Excel's behavior launches. – Sun Oct 7 '14 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.