0

Running Windows 7 Enterprise (64-bit), the Windows Search fails to find SSMS SQL files saved to a default location that ends up in Dropbox. Some details:

  1. My Documents live under a dropbox-controller folder: C:\Users\david\Dropbox (Personal)\My Documents

  2. SQL Server Management Studio saves files there: C:\Users\david\Dropbox\My Documents\SQL Server Management Studio

  3. This location is supposed to be indexed (went to "Indexing Options", Modify, and made sure that this folder is checked in the list)

  4. Tried re-creating the entire index, no avail

Windows search works in general, including locations in Dropbox, but just not for the SSMS folder!

I wrote a piece of code that uses OLEDB to dump the names of all the indexed files, and indeed, the folder in question was not in the index. What could be causing this? Too long of a path? Some Dropbox weirdness?

0

If you used .SQL as the file extension, this is not indexed by default. You need to add the file extension to Windows Search.

  • Control Panel > Indexing Options

  • Click Advanced

  • Add sql (or whatever is in your SMMS folder) as a new file extension

enter image description here

  • Already had this set as a Plain Text Filter with Index Properties and File Contents. The indexing works for SQL files in general, it just doesn't work for this particular folder. I wonder if it has anything to do with My Documents living in Dropbox, but even then, it's just one particular folder which never gets indexed. – davidair Oct 14 '14 at 22:52
  • You can investigate the security on that folder. Perhaps take ownership of it or use procmon to see how windows search index interacts with that folder. I know windows search will not let me see the actual index files. Perhaps similar security with that folder. There is also the ubiquitous reboot. – Sun Oct 15 '14 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.