0

I'm working in Ruby on Rails under MacOSX 10.9 in VMware Workstation 10. I moved my RoR project folder from the Desktop into my VMware shared folder. The reason is because some character's location are in the wrong place on my Hungarian keyboard (Macintosh Hungarian keyboard is different). So I want to code on the host machine, but I need Mac because of the great Terminal (workig under Windows in Git Bash sucks) and Xcode (that's why not Linux).

I want to push to github, but I got the following error, when I comitting:

Lanti-Mac:pinteresting lanti$ git commit -am "Repo moved to shared folder"
error: insufficient permission for adding an object to repository database .git/objects
error: .gitignore: failed to insert into database
error: unable to index file .gitignore
fatal: updating files failed
Lanti-Mac:pinteresting lanti$ 

I think there is some permission issue, or the NTFS file system causing this on my Windows.

Can We fix this?

UPDATE:

The .git folder's permission:

drwx------  1 root  wheel   4096 Sep 25 21:24 .git

Inside .git:

Lanti-Mac:.git lanti$ ls -al
total 84
drwx------  1 root  wheel   4096 Sep 25 21:24 .
drwx------  1 root  wheel   4096 Sep 25 20:55 ..
-rwx------@ 1 root  wheel   6148 Sep 25 19:57 .DS_Store
-rwx------  1 root  wheel   4096 Sep 25 19:59 ._.DS_Store
-rwx------  1 root  wheel     25 Sep 25 18:59 COMMIT_EDITMSG
-rwx------  1 root  wheel     23 Sep 24 14:48 HEAD
drwx------  1 root  wheel      0 Sep 24 14:48 branches
-rwx------  1 root  wheel    311 Sep 25 20:55 config
-rwx------  1 root  wheel     73 Sep 24 14:48 description
drwx------  1 root  wheel      0 Sep 24 14:48 hooks
-rwx------  1 root  wheel   6966 Sep 25 21:10 index
drwx------  1 root  wheel      0 Sep 24 14:48 info
drwx------  1 root  wheel      0 Sep 24 15:06 logs
drwx------  1 root  wheel  12288 Sep 25 20:56 objects
drwx------  1 root  wheel      0 Sep 24 16:09 refs

I can't change anything with $ sudo chmod 777.

"Get Info" -> Sharing & Permissions" says: "You have custom access".

It looks like for me that VMware quest can't have full access to the shared folders hosted by the host machine... Which is sucks, because I can't code fast in the quest... :(

"$ id lanti" reporting this:

Lanti-Mac:pinteresting lanti$ id lanti
uid=501(lanti) gid=20(staff) groups=20(staff),401(com.apple.sharepoint.group.1),12(everyone),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),33(_appstore),100(_lpoperator),204(_developer),398(com.apple.access_screensharing),399(com.apple.access_ssh)

The other option would be to install custom keyboard layouts into OSX.

UPDATE - SOLUTION:

I created a custom keyboard layout with Ukelele:

http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=ukelele

  • My virtual MacOSX can't change the permission of the shared folder. The shared folder is under the Windows host. – Lanti Sep 25 '14 at 21:56
  • What does a ls -al of .git and .git/objects report? What does id report? – ssnobody Sep 25 '14 at 23:53
  • I updated my question. – Lanti Sep 26 '14 at 7:48
  • OSX 10.9 in VMware Workstation 10. I Huh. Do you mean VMfusion (which runs on OSX) or windows X (10) and Vmware workstation (which does not run on OSX). – Hennes Feb 12 '16 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.