Everything was working fine in Win7 Ultimate until one day, I could not switch users. I had to enable fast user switching in regedit for some reason and locked the computer, hit ctrl+alt+del (never had to do this before) and tried to log into another account but i got the message

logon denied only one user session is allowed

I've been googling for a while but I can't seem to find the answer. Could someone please help?

  • 1
    Is this a remote desktop connection? Commented Sep 26, 2014 at 2:01
  • @CanadianLuke no, it's a local one. Commented Sep 26, 2014 at 23:49
  • Could someone please help me with this issue? Commented Oct 9, 2014 at 3:33
  • please? I don't have points to start a bounty. Commented Nov 2, 2014 at 15:23
  • I found that the PC had Cisco any Connect with VPN installed. Once I removed that the error went away and FUS started working. Commented Sep 12, 2019 at 21:26

3 Answers 3


I am not sure..but i think you turn off Fast user switching,because it is a functionality on modern multi-user operating systems which allows multiple user accounts to log on to a computer simultaneously and then quickly switch between them without quitting applications and logging out.

The reason for turned off Fast user switching is

  • First, this could be a security policy requirement. A security requirement might be that a user should completely quit all applications and log off from the computer after finishing his or her work on the computer.

  • By disabling the fast user switching feature, you hide the Switch user button in the Logon user interface, in the Start menu, and in the Task Manager.

  • Another reason could be performance issues. The fast user switching feature uses some system resources which can be freed in case the fast user switching functionality is not needed.

The above reason you tried to log into another account but you got the message

logon denied only one user session is allowed
  • I do not understand what you mean. Are you saying that I should disable FUS and not switch users on my PC? Commented Sep 26, 2014 at 23:59
  • yes,you should disable FUS the problem will be solve(see that reasons). What the reason did you enable?
    – Dharma
    Commented Sep 27, 2014 at 5:08
  • Disabling FUS disables the ability to switch users. I appreciate your efforts but that didn't solve my problem. Commented Sep 27, 2014 at 20:35

Looks like I had an issue with corrupted profiles. Finally fixed it. I can switch users now.

  • 2
    For the benefit of others with a similar problem, can you expand on what you found and how you fixed it? Thanks.
    – fixer1234
    Commented Oct 2, 2015 at 23:23

I know in your case this was on a local session, not a RDP session, but I just ran into this same error message via Remote Desktop.

Thanks to the comments, I saw that Cisco AnyConnect is a likely culprit. I stopped all four Cisco malware services in services.msc and I could login.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .