I have just set up Ubuntu 12.04 in a VirtualBox (v. 4.3.15) under windows 7 host.

I set clipboard and drag-and-drop to be directional.

I can copy and paste from the Ubuntu to the windows side.

Copying from Windows to Ubuntu comes out empty.

I have installed Guest Additions. The only thing I found in posts from people about clipboard not working, I tried...

$ sudo killall VBoxClient
$ sudo VBoxClient-all
$ ps -ef | grep -i vbox
root       806     1  0 08:20 ?        00:00:00 /usr/sbin/VBoxService
root      2444     1  0 08:55 ?        00:00:00 /usr/bin/VBoxClient --clipboard
root      2455     1  0 08:55 ?        00:00:00 /usr/bin/VBoxClient --display
root      2460     1  0 08:55 ?        00:00:00 /usr/bin/VBoxClient --seamless
root      2465     1  0 08:55 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
me        2470  2376  0 08:57 pts/3    00:00:00 grep --color=auto -i vbox

What else can I try ?

Edit: Even though I selected bi-directional drag-and-drop, it does not work in either direction. I did not test that initially since I mounted a share and been copying files through command line... But may be relevant information the fact that, while mounting manually a share worked, I cannot browse through the network folders, I get an error "Unable to mount location. Failed to retrieve share list from server". I do not particularly care to solve that issue unless it is a cause of the copy/paste problem, which is very annoying.

  • VB 4.3.16 here, host OS is Ubuntu 14.04, guest Win XP. "BI-derctional" mode works fine. Make sure you use the right paste-method - e.g. the Terminal uses SHIFT-CTRL-V as CTRL-C, V and X are used for other things. – Hannu Sep 26 '14 at 16:34
  • I have a different version of Ubuntu installed on another VM and i have no problem with it in the same VirtualBox environment - and I right-click to paste but there is nothing happening. Same inside gedit. So I wonder if it is the Ubuntu version that gives problems ? Some configuration option ? I did nothing different in setting up the two machines. – Thalia Sep 26 '14 at 17:45
  • Might be, check virtualbox.org for supported distros, might be they have some quirk with 12.04. – Hannu Sep 26 '14 at 17:53
  • Ubuntu 5.10 / 6.06 Desktop / 7.04 - 12.10 Works, with Additions ---- does that mean that they stopped supporting Ubuntu in 2012 ? That would be surprising... but there is nothing specifically about 12-04. – Thalia Sep 26 '14 at 17:59
  • Note: I haven't got the slightest idea, check their site. If an old distro stopped working for you why not upgrade? See ubuntu.com/info/release-end-of-life for version still supported with both hardware and maintenance. – Hannu Sep 26 '14 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.