3

So, any website that I try to open up in Firefox just won't load, it's not just particular websites. But all other browsers - IE, Chrome and Opera, do.
What I have tried:
* Checked Comodo's firewall about Firefox, didn't see anything
* Reinstalling Firefox
* Flushing DNS
* Checked Firefox proxy settings
* Resetted Firefox to it's original state on "about:support"

I'm out of ideas now and fast googling wouldn't give me any good answers.

Thanks for helping!

edit
OS: Windows 7
Internet connection: Wired, 12/1
When/how did this problem start: The person who I'm helping does not remember that he had done something that might've caused the issue.

| improve this question | | | | |
  • What's your operating system? What kind of internet connection? When/how did this problem start? – Daniel R Hicks Sep 26 '14 at 20:46
  • 2
    1) Have you tried Firefox Portable? Can you get to web sites? 2) Rather "reinstall", I would suggest you try uninstall, then install a fresh copy of Firefox. There is a difference especially if there are corrupt files that are not being replaced. – Sun Sep 26 '14 at 21:29
  • Do you have any ad-blocker installed in Firefox? – Soren Sep 26 '14 at 23:51
1

You can try creating a new profile following the official instruction here: Use the Profile Manager to create and remove Firefox profiles.

A new profile will not contain previous settings, while re-installation of Firefox may have kept the old settings that were messed up. I'm not sure whether it has the same effect as "Reset" in about:support.

| improve this answer | | | | |
  • 1
    Please summarize the content of external links so future users do not have to follow them to get the gist of what you're saying. – Wes Sayeed Sep 26 '14 at 23:38
0

I had ths problem and the only solution I found was to delete my WINDOWS user account and create a new one.

TO do this, you will need another account in the same computer, with administration rights.

  1. Exit your user account and reboot computer
  2. Logon to the other account with administration rights
  3. Delete your bugged account by doing this:

    a. start menu -> run

    b. type sysdm.cpl and press Ok

    c. Go to Advanced tab

    d. Click on the button inside the User Profiles square

    e. Remove the desired user profile

  4. Log off from the other account and logon to your account once again.

  5. If this doesn´t work (like if windows created for some reason a temporary profile), try again but use this instead of previous step 3:

    a. delete your account folder in c:\Users

    b. Open Regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    c. Find a folder that has a reference to your user profile inside

    d. delete this folder

| improve this answer | | | | |
0

I can think of a fewpossible likely causes -

  1. Firefox has reconfigured itself to use a prixy (or reverse in a corporate environment which requires a proxy). You can check by comparing network settings between IE and Firefox.

  2. Malware incorrectly trying to hijack the browser. Try running Malwarebytes and removing PUPs (software you were tricked into installing)

  3. A corrupt browser cache/setup. Try clearing your cache. If this doesnt work - it probably wont - close down your browservand move/delete your profile for it so that FF reunitialises itself. This will cost you your settings, bookmarks, saved passwords ectc though.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.