-1

I've been trying to configure my macbook (10.9) with ice floor and openvpn to prevent outbound connections from my real IP. So i had to allow connection between my real IP and OpenDNS so as to be able to connect to my VPN. All works fine but when I disconnect wi-fi or when the computer restart/wake it can't connect to the VPN because the system sends queries to the DHCP assigned DNS (in my case shaw) which are blocked by my firewall. It works again when disable/enable wi-fi interface as DNS queries are sent to OpenDNS. I really don't understand.

So, How can I force the system to use the manual DNS and never use the one from DHCP ?

Thanks

EDIT : Some more Informations

When OpenVPN can't connect (queries to those server are blocked by firewall) :

localhost:~ Charlie$ scutil --dns DNS configuration

resolver #1 nameserver[0] : 64.59.144.92 nameserver[1] : 64.59.150.138 if_index : 4 (en0) flags : Request A records reach : Reachable

But networks settings show OpenDNS not those one.

And when everything works the command above return OpenDNS servers.

0

If you are on the same network most of then just go to System Preferences > Network and change Wifi from DHCP to Manual.

This way you can enter right information just once, and only deal with problems when you visit "some" of the networks, since most routers will have same ip (192.168.1.1). Preferably set your Ip to 192.168.1.240, because it is rare that you will find computer with such high ip address.

  • I thought of that but it does't solve my problem because OpenVPN can't even go to the first step of connection (which is resolve DNS) and is totally blocked despite if I'm using a fix IP which is the same than the one DHCP provided to me. – Lich4r Sep 27 '14 at 22:33
  • Well you said that in your case problem is that your computer fails to use proper DNS server, this will let you choose right DNS server by default. – sgp667 Sep 28 '14 at 2:17
  • Point of manual settings is that you pick your own DNS server, rest of settings just have to be compliant with router on your network. – sgp667 Sep 28 '14 at 2:19
  • When I put on manual, openvpn can't even try to resolve DNS. It's totally blocked – Lich4r Sep 28 '14 at 5:06
  • Then I'm not sure if DNS is the problem. Maybe someone should take a look at the computer, because they can get fuller picture of the problem. – sgp667 Sep 28 '14 at 19:23
-1

Seems like editing openvpn profile by adding

push "dhcp-option 208.67.222.222" 

and same for the other DNS solved the problem here.

protected by bwDraco Jan 11 '16 at 6:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.