6

Illustration of the problem

When a web page in Firefox switches to full-screen then even though the website is allowed to switch to full-screen automatically (Tools > Page Info > Permissions > Enter Fullscreen) Firefox show this annoying message for whole three seconds: enter image description here

I know that I can disable the messages using this option full-screen-api.approval-required: false. Unfortunately this option disables the message also for unapproved websites and the approval confirmation "Remember this decision for ..." does not ever show up: enter image description here

The question

I do not want to undergo the security risk and disable the messages completely but the message from the first screenshot is too obtrusive for me. Is there any solution? For me ideal would be to show the message for a considerably shorter time like half a second. I also can accept not showing it at all but only for allowed websites.

Related questions

2 Answers 2

4

While this won't change the duration of the message, you can customize the message size, colors, border of the box and transparency with the UserChrome.css file. This will make the fonts smaller, for example:

#full-screen-warning-container {
    background-color:transparent !important;
    opacity: 0.4 !important;
}

#full-screen-warning-container[fade-warning-out] {
    transition-property: opacity !important;
    transition-duration: 1ms !important;
    opacity: 0.0 !important;
}

#full-screen-warning-message {
    padding: 15px !important;
}

.full-screen-description {
    font-size: 100% !important;
}

#full-screen-domain-text {
    font-size: 100% !important;font-weight:bold !important;
}

.full-screen-approval-button,#full-screen-remember-decision {
    font-size: 100% !important;
}

You can modify this code to position the box at an edge of the screen and make it appear only when you move your mouse over it.

2
  • Thank you. I forgot that it is possible to modify a lot of appearance using CSS in Firefox. --- In addition to your code (and making the box even smaller) I have made the warning transparent: #full-screen-warning-container { opacity: 0.4 !important; } and shortened the fade-out: #full-screen-warning-container[fade-warning-out] { transition-property: opacity !important; transition-duration: 1ms !important; opacity: 0.0 !important; }. --- The showing time of 3 sec seems to be hard-coded here: lxr.mozilla.org/comm-esr31/source/mozilla/browser/base/content/… Mar 11, 2015 at 13:34
  • I'm glad that it was helpful for you. You can edit my answer to add these attributes to it and mark it as the chosen answer. :)
    – user33758
    Mar 11, 2015 at 13:36
1

Actually, you can suppress the warn if you want.

Just go to "about:config" and modify the value of "full-screen-api.approval-required" to false (is a boolean) and firefox will not warn you at all.

I understand that create a 'userChrome.css' solution pointed above is a better option to who want to control the appearance, I just giving this answer to anyone who might search for someone who want to get rid of this warning and ends up here from google.

1
  • 2
    The OP has already mentioned this.
    – suspectus
    Aug 12, 2015 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.