9

I went to add an alias to a forwarded address (managed by GoDaddy, ie myemail@mydomain.com) in Gmail, and I noticed that Google changed their system. In the past, after you entered the name and email address, you'd get a screen like this:

Before

However, now they seem to be requiring SMTP information:

Now

I did some research and contacted GoDaddy, but it seems that you have to register an actual email address, not a forward in order to add it as an alias in Gmail.

It should be noted that all aliases to forward addresses that I'd previously set up work fine, I just can't edit them or add new ones.

Does anyone know of a workaround for this or why this would have changed? Thanks!

9

I figured out a way to do this.

Use the Gmail SMTP server. Create an application specific password.

This is essentially the manual way to "send as an alias" with gmail.

I don't know why they removed the Alias functionality, but this is how to make it work.

I've written a more detailed step-by-step tutorial with screenshots and links here: http://ellisbenus.com/web-design-columbia-mo/workaround-using-gmail-alias-forwarded-email-addresses/

| improve this answer | |
  • 5
    This doesn't work anymore - There is no "App Passwords Settings". Try this link tjkelly.com/blog/gmail-godaddy-email-forwarding which is a more recent blog on how to. Good Luck. – Akash Jan 7 '16 at 8:04
  • @AakashShah worked for me! – rebello95 Jan 27 '16 at 5:25
  • @rebello95 thats good. Are you already with 2-factor-authentication on your google account? – Akash Jan 27 '16 at 9:23
  • @AakashShah yep I am – rebello95 Jan 27 '16 at 13:11
  • 1
    @AakashShah yeah you have to have it enabled in order to use app specific passwords. Otherwise it doesn't work – rebello95 Jan 28 '16 at 11:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.