0

Attempting to install ruby 2.1.2 on a centos 7 box, but running into a dependency issue with openssl

~ % ruby-install ruby

...blah blah blah...

---> Package openssl-devel.x86_64 1:1.0.1e-34.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
---> Package pcre-devel.x86_64 0:8.32-12.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:openssl-devel-1.0.1e-34.el7.x86_64 (base)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-34.el7
           Installed: 1:openssl-libs-1.0.1e-34.el7_0.3.x86_64 (@updates)
               openssl-libs(x86-64) = 1:1.0.1e-34.el7_0.3
           Available: 1:openssl-libs-1.0.1e-34.el7.x86_64 (base)
               openssl-libs(x86-64) = 1:1.0.1e-34.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
!!! Installing dependencies failed!

The crazy thing is it looks like I already have the desired package:

~ % yum list installed |grep ssl
openssl.x86_64                  1:1.0.1e-34.el7_0.3                    @updates
openssl-libs.x86_64             1:1.0.1e-34.el7_0.3                    @updates

What can I do to satisfy the SSL dependency?

Next I tried:

~ % yum install -y openssl-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: sg2plmirror02.shr.prod.sin2.secureserver.net
 * epel: mirrors.mit.edu
 * extras: sg2plmirror02.shr.prod.sin2.secureserver.net
 * rpmforge: mirror.us.leaseweb.net
 * update: sg2plmirror02.shr.prod.sin2.secureserver.net
 * webtatic: us-east.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.1e-34.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.11.3-49.el7 will be installed
--> Processing Dependency: libverto-devel for package: krb5-devel-1.11.3-49.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.11.3-49.el7.x86_64
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.11.3-49.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.11.3-49.el7.x86_64
---> Package openssl-devel.x86_64 1:1.0.1e-34.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package libcom_err-devel.x86_64 0:1.42.9-4.el7 will be installed
---> Package libselinux-devel.x86_64 0:2.2.2-6.el7 will be installed
--> Processing Dependency: libsepol-devel >= 2.1.9-1 for package: libselinux-devel-2.2.2-6.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.2.2-6.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.2.2-6.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
---> Package openssl-devel.x86_64 1:1.0.1e-34.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
--> Running transaction check
---> Package libsepol-devel.x86_64 0:2.1.9-3.el7 will be installed
---> Package openssl-devel.x86_64 1:1.0.1e-34.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-devel-1.0.1e-34.el7.x86_64
---> Package pcre-devel.x86_64 0:8.32-12.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:openssl-devel-1.0.1e-34.el7.x86_64 (base)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-34.el7
           Installed: 1:openssl-libs-1.0.1e-34.el7_0.3.x86_64 (@updates)
               openssl-libs(x86-64) = 1:1.0.1e-34.el7_0.3
           Available: 1:openssl-libs-1.0.1e-34.el7.x86_64 (base)
               openssl-libs(x86-64) = 1:1.0.1e-34.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The error message is terribly obscure.

0

Looking at:

Package: 1:openssl-devel-1.0.1e-34.el7.x86_64 (base)

, I remembered modifying the CentOS-Base.repo file to include additional mirrors along with some other changes when setting up my box. Unfortunately I'm not sure what change triggered the error.

I was able to fix the issue by reverting /etc/yum.repos.d/CentOS-Base.repo to the file found here: http://vault.centos.org/4.2/CentOS-Base.repo and running yum install openssl

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.