Trying to install Kali Linux but I am running into an error as soon as I begin.

I have a Toshiba Portege 64bit machine running a Windows 7 operating system. The HDD has two partitions. I downloaded the Kali Installation 64bit iso and have checked the Sha1 provided with the installation to be correct using fciv.
I burned the iso on a DVD and proceeded with the installation. When booting I get the Kali splash screen with all the options but whichever option I choose my laptop beeps and the next thing I see is a blank screen. I had installed Backtrack on the same machine before and it installed just fine so I'm wondering what's different with Kali.

Kindly assist

  • Did you burn it on slow (best quality)? Easier to use a bootable flash drive to do it though. – Rsya Studios Sep 29 '14 at 6:18
  • I did a slow burn, the lowest my DVD ROM is capable of but still got the error, am kind of holding on to the hope i can install it through a DVD but if all fails i'll take the flash option....thanks – James Sep 29 '14 at 7:31
  • I eventually did a flash drive install using a bootable flash drive but i run into the same problem...any ideas on what could be causing this? – James Sep 30 '14 at 3:23

It might be, that Kali Linux cannot detect the video output it is supposed to use, hence not showing any output.

One possible fix is to enter your BIOS. Many BIOS give you an option which output (internal or external) Many times it is set to "both" in case you have a external Screen connected to your Laptop.

So... enter your BIOS, look for that option and set it to internal. This might fix it.

  • My BIOS does not have the options you mentioned ie (video In/Output). I went through the BIOS all the same but did not find anything in regards to affecting another OS installation, I had previously installed backtrack and its installation was flawless. After the deletion of backtrack i had problems with my MBR and had to overwrite it with a Windows7 OS Disc so as to be able to boot with windows coz Grub was deleted....could this be causing the error, also i have Kali installed in a virtual environment in windows but i doubt this could be the cause – James Sep 29 '14 at 8:59
  • Any other ideas on how to solve this? – James Sep 30 '14 at 3:24

I eventually solved the problem, apparently Kali 1.0.8 and 1.0.9 had the problem. Currently i have no idea why but maybe the efi features caused the booting stall. I downloaded Kali 1.0.7 and wrote it on a flash drive and voila!!...after a week of constant head scratching/banging it worked like a charm, i have now done all the updates and upgrades and still no problems....thanks for your input guys

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.