0

We've recently migrated to a Canon Uniflow follow-me print solution. When I try to print to this, from my machine it looks as if all's worked (i.e. a print dialogue pops up, I click OK, the sending to printer progress bar briefly displays, gets to 100% and the goes, and no errors show up). However checking the printer's job queue, no jobs are listed under my name. This solution works for all other users from their machines. The solution works for me when using a different machine. The solution works for other users on my machine - so it's machine-user combo specific.

I've tried deleting the printer & print driver (Canon Generic PCL6 Driver), restarting the computer, reconnecting to the printer installing the print driver, and restarting the print spooler. No luck. I'm running Windows 7 Pro SP1 on an x64 machine; same as most people in my office. I have admin rights on my machine (same as majority of those in the IT department, who have a similar setup). I've run MS Fixit (http://support2.microsoft.com/mats/printing_problems/en-gb) which reported the only "issue" as being the existence other jobs in the queue (i.e. implying my job was queued behind someone else rather than spotting that it's not showing). I've tried mapping directly to the printer on the print server, as opposed to via UniFlow; printing works, but bypasses the follow me feature (as you'd expect).

Has anyone experienced this before / any thoughts on what this may be?

Update

After further investigation we've found that my print jobs are being sent to the printer; just not under my account. They're consistently being sent under the Domain Admin's account. He's used my computer in the past / there were a few saved credentials under the terminal services registry keys and in the windows credential manager, but even after removing all of these and rebooting jobs are still being sent under his account. We've checked all processes and services for anything running under his name on my machine; nothing shows up. However when print jobs are sent, a "net session" shows a session between my machine and the print server, and checking the sessions on the print server the username against my IP is the domain admin's. Printing to other printers (i.e. not uniflow), the username displayed is mine).

  • NB: This issue has now stopped occurring. We never found the cause and there were no changes to printer, account or computer which may explain this sudden resolution. – JohnLBevan Feb 12 '15 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.