2

I have a windows 8.1 machine (recently installed) With UAC set to "minimum" and I'm starting regedit with "run as administrator"

If I try to create a new key under HKLM/System/CurrentControlSet/Services it successfully creates a key called "New Key #1" but when I try to rename it I get the error:

The Registry Editor cannot rename New Key #1. Error while renaming key.

From procmon I can see it's returning an "ACCESS DENIED" error from the RegRenameKey operation.

This seems to happen anywhere inside the services HKLM/System/.../Services but not elsewhere. I can create and delete keys at any level within here but cannot rename. I can rename values with no problem. Even above the services level I can rename keys

I have tried taking ownership of the parent and also resetting the permissions to give everyone full control. neither of these resolve the problem

  • 1
    Right click the registry key in the left pane and select Permissions. Click the advanced button. Are you able to change the permissons? – Leo Chapiro Sep 29 '14 at 14:37
  • Have you got and real-time anti-malware programs running? Does it behave the same way in Safe Mode? – Ƭᴇcʜιᴇ007 Sep 29 '14 at 14:43
  • yes, I can change the permissions and ownership with no problem, both on the parent and the key itself, but whatever the permissions are, I still get access denied trying to rename it. – Andy Sep 29 '14 at 14:43
  • Try a workaround: export the key to a .reg file, edit it (rename the key), delete the key and import .reg :) – Leo Chapiro Sep 29 '14 at 14:56
  • 1
    Yes that workaround works fine, but I'm still mystified as to the original problem. Disabling the anti-virus software didn't make any difference. I tried to restart in safe mode but as the boot drive is encrypted with BitLocker, it's not possible to boot in safe mode without doing a recovery which is more hassle than I'm willing to go to at the moment, given that I can use .ref files as a workaround. – Andy Sep 29 '14 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.