1

So I have this hard drive which died the Click Of Death after falling of a couch. As I cannot afford data recovery, I went the home-brew route. The head seemed broken, as I watched it moving without issues over the platter, but repeating the same movement cycle. According to the internets, this is a sign of a broken head, preamp or electronics. I ordered an identical harddrive off ebay (didn’t find it at hardware stores, otherwise I would have taken that route) and switched the head and the electronics board over to the dead one.

Now the click of death is gone, but the drive still isn’t accessible from the linux system. I’m getting errors like:

Sep 29 19:01:49 kernel: [ 3622.694043] ata5: softreset failed (device not ready)
Sep 29 19:01:49 kernel: [ 3622.694053] ata5: limiting SATA link speed to 1.5 Gbps
Sep 29 19:01:49 kernel: [ 3622.694058] ata5: hard resetting link

until:

Sep 29 19:05:37 kernel: [ 3850.100971] ata5: reset failed, giving up
Sep 29 19:05:37 kernel: [ 3850.100980] ata5: EH complete

I realize that it is likely that this drive is lost forever, but I wonder whether someone from around here has some experience with these issues may have one last hint.

  • The drive is a Seagate Barracuda 7200.10 360 GBytes.
  • As mentioned, I replaced the head and the electronics board. Replacing only the board doesn’t yield the desired effect either. The old head is by now definitely broken, so no way in trying the old head with the new electronics board.
  • I already tried a different SATA slot on my mainboard, to rule that out, although I used the very same cable and slot for another HDD just a few weeks ago without any issues.
  • When putting the drive into it’s original external USB enclosure, not even the USB to SATA converter is recognized via lsusb. I suspect that that might have been broken too during the fall, or I messed it up while getting the drive out of the box.
  • I tried booting with the drive instead of hot-plugging it into my PC, with no difference.

What really gets me is that the drive seems to be booting up (I hear it spinning up, I hear one short head movement), but doesn’t respond to ATA.

The question boils down to: Has anyone been in a situation similar to this and what are other steps to test for?

  • Exact drive model does not mean exact same drive electronics PCB. regardless, as-is this question is too brood IMO. You've tried about all you can try, time to give up, or send it to a professional and pay the $$$. – Ƭᴇcʜιᴇ007 Sep 29 '14 at 18:05
0

IT is likely the platter and board are found 'incompatibly matched'. Many mfr's have 'coded' the boards to the platter to keep them 'matched' for warranty purposes, against doing what you have done. The key is usually in the eprom chip on the original board. So you will have to change the chips from the original board to the replacement, assuming the main chip is not part of the problem. NO GUARANTEE this will work, mfr's have gotten smarter to 'swappers' who try to get 'defects' fixed under warranty. I applaud you for the effort you've taken it's not a simple task. I'd suggest finding a professional, or local educational facility and use PROPER solder / de-solder equipment. Foil runs fail real easy nowadays.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.