17

PROBLEM
Cannot run Windows 8.1 due to black screen. No mouse pointer. Sometimes white cursor in top left. Cannot enter safe mode: get black screen but with a row of blue pixels at the bottom or a row of red pixels at the top. Can enter repair environment when booting from DVD or USB. Can enter UEFI.

This ‘feature’ of Windows 8.1 is well documented on forums and is principally connected with updates. The threads that most closely match my experience are as follows:

Windows 8.1 Black Screen (identifies issue as to do with mixed video drivers and suggests replacing Windows.UI.Immersive.dll)

Black screen after boot (problem fixed itself after leaving computer for 45 mins)

HOW PROBLEM CAME ABOUT
The last steps I took in Windows 8.1 were as follows:

1) Have had problem installing 2 updates. One update was large (~800MB). Followed advice to delete update history on Windows server by deleting SoftwareDistribution folder. I renamed it instead and tried reinstalling the updates but still no success. So I deleted the new SoftwareDistribution folder and replaced it with the old one. Two new updates were installed in this troubleshooting process. I am afraid I do not have a record of the names of the updates because I cannot enter Windows 8.1 to see the history.

2) Given that the update installation did not work I scheduled a restart in safe mode with network so I could try installing the updates in safe mode.

enter image description here

3) On restarting the computer I got the black screen after the UEFI boot screen!!

SYSTEM
AMD A10-6800K APU with Radeon HD Graphics

4.10 GHz CPU

MSI motherboard with E7721AMS V11.2 BIOS

Corsair Force LS SSD 60GB (has Windows 8.1 64 bit installed)

WDC 1TB Harddrive (contains Windows user files through a system link which I made)

1 widescreen monitor

ACTION TAKEN TO TRY TO FIX PROBLEM
1) Replaced monitor (not wide screen) -- the first thing I did.

2) Left computer for a few hours to see if problem would go away but it didn’t. My guess is this may have worked the first time the problem occurred but it took me so many attempts to try to boot from the Windows DVD, and then the USB, and to try to get to safe mode that I would have pressed a lot of keys before trying just to leave the computer to see if it would fix itself.

Following tried from Windows repair environment after booting from DVD or USB

3) Searched for Windows.UI.immersive.dll on entire Windows harddrive but was not found with the dir [filename] /s command at the command prompt.

4) Automatic repair was unsuccessful.

5) Refresh PC gave error “The drive where Windows is installed is locked. Unlock the drive and try again.” One webpage said that Windows could have forgotten the proper drive/partition order and that unplugging the non-Windows harddrive might help, but I got the same error on re-running the Refresh option.

6) Tried forcing Windows to give boot options so I could select safe mode. Neither F8 nor Shift+F8 started safe mode. Tried the following line in command prompt: bdcedit /set {default} bootmenupolicy legacy. Error given: “The boot configuration data source could not be opened. The requested system device cannot be found.” One thread said that this could be due to running Windows recovery from a USB drive so I tried running it from different USB ports as well as from the DVD but it made no difference to the error.

7) Ran chkdsk d: /f /x from command prompt. First run: the only error found was that some free space was marked allocated. Second run: all clear. This did not fix the problem and I was still getting the black screen when at the end of the boot sequence.

8) Tried to run command sfc /scannow (recommended here) but got following error: “Windows Resource Protection could not start the repair service”

QUESTION
In order to fix the problem it seems like I have to get Windows to boot using low resolution VGA and then enter windows to either roll-back some updates or make sure all updates are installed properly.This strategy is corroborated by this webpage: http://www.itpro.co.uk/desktop-software/22313/windows-81-problems-how-to-fix-them

Any ideas about how I can do this?
All help greatly appreciated.

I can enter the recovery/repair environment but cannot enter safe mode. This environment has a tile for UEFI settings but does not have a tile for Startup settings.

  • 4
    Excellently written question. – Nifle Sep 30 '14 at 5:23
  • Any luck on this? I am seeing the same issue here with a laptop whereon I had updated a video driver and then upon reboot I get NOTHING. This dreaded black screen is not anything that can be bypassed. Using repair mode option upon hitting escape likewise starts with the black screen after the logo shows and the throbber spins for a bit. – ylluminate Oct 9 '14 at 17:03
  • Can you even see the F8 menu? If so try using "low resolution mode" – Hefewe1zen Oct 10 '14 at 19:41
  • 1
    Thank you for the responses and the additions of reputation. I couldn't wait any longer for a response so reinstalled already. I am afraid I can't test @harrymc's solution anymore but I would have like to. – Ad Astm Oct 14 '14 at 13:11
  • 3
    Unable to reproduce (OP has reinstalled) – DavidPostill Nov 3 '14 at 13:11
0

you can try replacing Windows.UI.immersive.dll

Step 1 : go to system32 subfolder in Windows folder (typically C:\Windows\System32)

Step 2 : Find the Windows.UI.Immersive.dll,check for Date Created attribute(if it is old one,you may have to replace with the recent one)

Step 3 : Goto WinSxS subfolder in Windows folder,search for Windows.UI.Immersive.dll(which is newer version) ](can found it in C:\Windows\WinSxS\x86_microsoft-windows-windowsuiimmersive_31bf3856ad364e35_6.3.9600.16408_none_c6ca1a15ef5e5709)

Step 4: Replace the older file with the newer one in system32 folder

Step 5: there is a hidden folder called Windows Activation Technologies in root drive(usually C:\Windows Activation Technologies),replace the older file in the above folder too. Then restart, hopefully this solves your problem

Not the answer you're looking for? Browse other questions tagged or ask your own question.