1

For quite a while, I have used Firefox on my Windows 7 laptop and a single profile. When I open up Outlook or Pidgin or whatever, and I click on a link, that link opens up as a new tab in my Firefox window. So far so good.

Now I have two profiles, one for regular day-to-day browsing, and one for work-related browsing with specific settings and proxies and whatnot. I left the original profile with the name "default". Now, however, when I click on a link in Outlook or Pidgin or whatever, I get the Profile Manager popup, asking me which profile I would like to use. I select "default", and I get an error 'Firefox cannot use the profile "default" because it is in use.'

Clearly I have screwed something up that prevents Firefox from just opening a new tab in my default profile like it always used to. But I can't figure out what that is. Does anybody have a pointer?

This is my entire profiles.ini file

[General]
StartWithLastProfile=0

[Profile0]
Name=default
IsRelative=1
Path=Profiles/eo47sbrx.default
Default=1

[Profile1]
Name=work
IsRelative=1
Path=Profiles/fakii06g.work
1

I eventually found this post

Is there a way to have Firefox profiles and switch between them?

which included this answer:

About -no-remote switch

  • There's another parameter -no-remote which you can use to have more than one profile opened at the same time.
  • There can be max one Firefox instance opened without this parameter, and infinitely many opened with this parameter
  • You can also open Firefox always with -no-remote switch. However, this comes with a drawback. Read below.

Keep mind that if:

  • Firefox is your default browser
  • you click a link in an external application (say, Word, PDF reader, or IM),

then:

  • it will be opened in the Firefox instance opened without -no-remote.
  • If you opened all instances of Firefox with -no-remote, you'll get an error message and the link will not be opened.

This was my problem. I was under the (mistaken) impression that all of my sessions had to have the -no-remote flag. Thank you @jakub-g

|improve this answer|||||
0

Your profile.ini seems to be correct, if the profile folders exist.

Try starting firefox from a shortcut using this

"C:\pathToFirefox\firefox.exe" -p "profileName" -no-remote

Also, create a shortcut to the profile manager, select default and click the Use slected profile without asking at startup this will set the default, instead of having to edit it manually as you did.

"C:\pathToFirefox\firefox.exe" -p

If the Default profile is broken, create another one and use it instead.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.