5

I have a Terminal Server setup on Windows server 2008 R2.

I am trying to log in to it with RDP, using the local admin account. (Not the domain admin) I have placed the local admin in the remote desktop users group, but I am still getting the following message trying to log in:

To log on to this computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group that has this right, or if the Remote Desktop Users group does not have this right, you must be granted this manually.

Any help will be greatly appreciated.

Notes:

I found a temporary solution; Installign LogMeIn, this logged me in to the local admin account, remotely without problems

  • The server IS part of a domain.
  • Domain users placed in RDP users group can successfully login without any problem.
  • I have placed the local admin, inside the local RDP group. (And it is not working)
  • The TS server is a 'vigrin' system
  • The AD/DNS are not 'virgin'.
  • There are NO restricted groups, yet.
  • I am using \Administrator as a login (This avoids domain logins)
  • Also tried Computername\Administrator and .\Administrator
  • Domain functionality level is Windows Server 2008 R2
  • Cannot alter group policy: "Allow log on through Remote Desktop Services" (the add button is greyed out) +

+: A following note on the group policy; It states that "This setting is not compatible with computers running Windows 2000 SP1 or earlier. Apply group policy objects containing this setting only to computers running a later version of the OS.

  • Is the server actually part of a Domain? Did you add the user account to the Remote Desktop Users group of the machine itself? If on a domain, are there currently any GPOs setup on the domain that control TS/RDS settings, and/or Restricted Groups? – Ƭᴇcʜιᴇ007 Oct 1 '14 at 15:41
  • Updated/Edited my question. – Remy van Tour Oct 1 '14 at 15:44
  • Have you successfully logged in locally (at the console) using that local Admin account? Are you specifying the machine name (or .) as the domain when attempting to log into the machine via RDP? – Ƭᴇcʜιᴇ007 Oct 1 '14 at 15:49
  • I have normal access when logging on physically. – Remy van Tour Oct 1 '14 at 15:52
10

\Administrator won't use the RD server machine as the domain.

You either need to specify the server's computer name (remoteComputerName\Administrator), or use a dot (.\Administrator) to tell the remote computer that the domain for the credentials is itself.

  • Tried your way, same outcome. (Tried full PC name and .\ ) When using just \ it just doesn't register a domain. – Remy van Tour Oct 1 '14 at 16:47
  • 1
    This worked. I needed the FULL name -- ex. pcname.localnetwork.dmz\MyUser for it to work for me. – emragins Apr 14 '16 at 16:30
  • 2
    Be aware that there is a difference between .\MyUser (use my local PC as remote domain) and \MyUser (use local account). So if you want to log on with RDP as the local Administrator, you would simply type: \Administrator. – Dag Wieers Aug 21 '17 at 16:24
  • The .\ notation works if you setup a server group, and have the credential at the group level. You must have the server settings inherit from the parent. RG – Rob Teckie Jul 26 '18 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.