2

I'm trying to install Windows 10 preview on Mac OS X with Parallels, but the ISO file is not recognized by Parallels. The ISO is not defect, I've checked the Hash.

2
  • have you tried to to manually drag the ISO into the browse for ISO window?
    – squareborg
    Oct 1 '14 at 18:53
  • Yes, I did. I have had to proceed anyway. It works now.
    – Sankp
    Oct 1 '14 at 19:46
3

Drag the ISO, it says it doesn't recognise it - Click Proceed anyway...

Mine is plodding away nicely right now - prompted by this question, in fact; though I wasn't going to bother...

This is assuming you have Parallels 10 - can't say how 9 or lower would behave

3

I had a similar problem installing the WindowsPreview in Parallels 9.

Solution

  1. Clone an existing Windows 8.1 VM
  2. The bit-levels of the VM and the downloaded WindowsTechnicalPreview.iso have to be the same (64-bit>64-bit or 32-bit>32-bit respectively ).
  3. Mount the WindowsTechnicalPreview.iso in the VM and install with setup.exe. You will be asked if you want to keep your private files or wipe all.

Windows 8 and 7 should work as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.