1

When I open the containing folder for a download in Firefox it launches kdesvn (which then fails).

This isn't listed in the Applications tab in the Preferences window, and grepping kdesvn in ~/.mozilla doesn't find anything, so I suspect it's some kind of system-wide setting not particular to Firefox. Then again, I never see kdesvn being chosen to open a directory in any other circumstances.

What is responsible for choosing kdesvn as the application to open directories with?

For bonus points, is there a way to remove a given application from all file associations at once (I know how to do it individually)?

I am using Kubuntu 13.10

1

Here's a start:

From a shell, try using xdg-open on a directory:

$ xdg-open ~/Downloads

If this does not reproduce the problem, then firefox is using some other mechanism of determining the application to use.

We can figure out what program is set as default like so:

$ xdg-mime query filetype ~/Downloads
inode/directory
$ xdg-mime query default inode/directory
dolphin.desktop

And we can set the default like:

$ xdg-mime default dolphin.desktop inode/directory
1

I had a similar problem, except it was Cervisia starting up rather than kdesvn (that I don't have).

I fixed it as follows:

  • Open KDE System Settings
  • Go to File Associations
  • Filter on "directory" to locate the inode/directory entry
  • Move Cervisia down.
  • Apply change and test: Dolphin fires up when opening containing folder from Downloads.

I subsequently put Cervisia back in the right place and it still works. So I suspect some form of corruption of the ordering which is fixed by making a change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.