51

I am trying to install VirtualBox guest additions on Windows 10 technical preview, and am getting the following error:

Cannot be installed

I imagine I am not the only one having this issue, is there any way to force it to install?

  • 1
    You actually got it to install on VirtualBox? o_O – kinokijuf Oct 2 '14 at 20:09
  • 6
    Yup. Just pick windows 8 (NOT OTHERS) as the vm type on a suitable host. Also runs fine on KVM, and vmware. – Journeyman Geek Oct 2 '14 at 23:55
  • @Journeyman Geek: For me, it installed using Other Windows as the VM type (i.imgur.com/hNCwJVG.png). Maybe the host OS matters? I use Kbuntu 12.04 (32 bit). – Silviu G Oct 22 '14 at 11:02
  • hm. Maybe cause I'm running a 64 bit guest on a 64 bit system on mine. – Journeyman Geek Oct 22 '14 at 14:48
  • 1
    @JourneymanGeek He's specifically asking about the installing the VirtualBox Guest Additions in the guest, not installing the OS in a VM. – Jonathon Reinhart Oct 23 '14 at 0:30
25

Use of Windows Compatibility settings (or use /force) will not work: installer will run, but with no real effects.

Install VirtualBox 4.3.18 or newer. It has improved compatibility with Windows 10.

Note: Menu Help > Check for updates may not reflect the newest as being the latest. Download it manually instead.

Download of New Versions

Windows Host: download here. Please, check the Virtualbox Download page for latest.

Ubuntu Host: run the following commands to register the virtualbox.org repository with the package manager and update from it:

sudo add-apt-repository "deb http://download.virtualbox.org/virtualbox/debian xenial contrib"
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-5.2

According to your distribution, replace xenial with zesty, yakkety, xenial, vivid, utopic, trusty, raring, quantal, precise, stretch, lucid, jessie, wheezy, or squeeze.

Others: Check the download page here.

  • Thank you. VitualBox 4.3.18 works with Windows 10. Do you know, why checking for a new version from VirtualBox menu shows me that latest version is already installed, but it is not? – Alexander Logger Oct 27 '14 at 20:23
  • For Macbook Pro running OSX 10.9.2: Right-click VBoxWindowsAdditions-amd64.exe in the Windows 10 VM, choose properties and set the compatibility to Windows 7. Then "Direct 3D Support (Experimental)" won't be checked and you can proceed without install error. Source: 4sysops.com/archives/… – Loren Oct 31 '14 at 12:03
50

It's a preview version, so I suspect it's doing naive version checking. An update for VirtualBox or Windows 10 should do the trick eventually.

For now, right click on it, select Properties, the Compatibility tab, and select Windows 8 compatibility there. Much easier than using the compatibility troubleshooting I did initially.

However, the drivers don't actually seem to work once installed, so an update would probably be needed. (Can't believe I actually missed that.) Once again, it's a preview version, and it doesn't quite work right.

  • 4
    Cheers, yeah I ended up re-installing on vmware which worked much better :) – JMK Oct 2 '14 at 13:39
  • 5
    Nice visual, very clear answer! +1 – Raystafarian Oct 2 '14 at 14:01
  • 1
    It works alright for me sans additions. Also seems to work alright on KVM on another box. – Journeyman Geek Oct 2 '14 at 14:09
  • 20
    Why do people click Apply and then OK? – Josh M. Oct 2 '14 at 22:33
  • 3
    Good question. I have no idea either. Pavlovian conditioning? – Journeyman Geek Oct 2 '14 at 23:54
23

Use the Force...

VBoxWindowsAdditions.exe /force
  • 4
    This worked, but also locked up my Windows 10 TP vm after a reboot – twig Oct 2 '14 at 23:54

protected by nhinkle Oct 2 '14 at 16:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.