4

I tried installing GNOME packages to Ubuntu 14.04(unity). I used these codes.

sudo apt-get install gdm

sudo apt-get install gnome-shell

sudo apt-get install ubuntu-gnome-desktop

sudo add-apt-repository ppa:gnome3-team/gnome3-staging

sudo apt-get update

sudo apt-get dist-upgrade

sudo apt-get install gnome-weather gnome-music gnome-maps cheese gnome-documents

That did not do well, So i removed them completely using

sudo apt-get remove gdm

sudo apt-get remove gnome-shell

sudo apt-get remove ubuntu-gnome-desktop

And now i am not able to change my desktop wallpaper.A right click on desktop is not working. I think it removed the necessary packages of Unity also .Even the login screen display has not changed from GNOME style to Unity style. Is there a way to regain the original Ubuntu unity style?

  • I have the exact same issue after installing then uninstalling gnome. Did you ever come up with a solution? – aw04 Jan 5 '15 at 1:50
7

Try this, it works for me:

gsettings set org.gnome.settings-daemon.plugins.background active true

However this case fits more to AskUbuntu, and almost indentical one has been answered: Desktop shows a white or black background instead of wallpapers (the solution above comes from there).

I had tried to comment your question but I have been unable to do it by lack of 50 reputations.

0

To reinstall Unity (default for Ubuntu) you can type in your terminal:

sudo apt-get update
sudo apt-get install ubuntu-desktop

After a reboot you should be able to choose a wallpaper again.

  • It did not work. I still face the same problem – Aravind S Oct 2 '14 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.